Nissan Forum banner

1 - 17 of 17 Posts
G

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Hello, I bought a 1996 200sx SE-R with a T3 turbo kit. The past month I've been having some strange problem. Here it goes....When I start my engine, the RPM meter is unstable.It will jump to 1 1/2 rpm and be unstable around the 1's... If I drive for a short period of time(IN ABOUT 10 TO 20 MINUTES OR SO), and I shut it down and start it back up The meter barely stays idle and drops, sometimes even going to zero,shutting it down. Also when I'm driving some times it drops to zero and stalls. Now when I drive for a prolong time, and I shut down the vehicle. I'm unable to start it back up untill I wait a good period of time (AN HOUR OR SO) I am uncertain what is it. Anyone with the magic answer I really appreciate it.
 
N

·
Guest
Joined
·
0 Posts
Discussion Starter #2
I had a similar problem with my speedometer on my 96 sentra....right after i got the car(about 3 days later) after many trips to the dealer, they thought the problem was the speed sensor, and oxygen sensor and replaced pretty much all the sensors, but didnt fix anything, all it ended up being was a bad speedometer itself, so it might be your tach that needs replacing...:D
 

·
Towards Antisocial
Joined
·
592 Posts
probably won't check back here but...

are you allowing the turbo time to cool , i.e. turbo timer?

If you have the trbotmr thats good. How many miles on the turbo?

Hmm... wonder why none of the big guns have had there say on this yet.
 

·
Towards Antisocial
Joined
·
592 Posts
are you maintaining constant boost pressure?
 

·
Registered
Joined
·
125 Posts
How is the car while driving. ----Does it have a hard to to rev? Does it run really rich? Migh be a bad air flow meter.. Check the ground and stuff.

i dunno if this helps but when I removed the hose going to my intake hose that leads to the back of the intake manifold by accident when changing my clutch the car started up then idled really crazy and died. It could not idle. Also Check the TPS
 

·
Red line chaser
Joined
·
814 Posts
Check all your vacuum hoses and also check the ground wire to your MAF meter. Have seen the latter wreak havoc on a few turbo SR20 owners trying to get them dialed in. This wire has a tendency to corrode somewhat, and as it does, the resistance of the wire increases, causing your MAF to get weird readings. Hope this helps a little.
 

·
pay your rent!
Joined
·
601 Posts
i dont have the sr20de but on my 95 ga16de it did the same thing untill finally it wouldnt start at all. finnaly with the dealer having my car for 2weeks (i couldnt figure it out :( ) the distributer needed replaced. this was the last thing i thought of since the spark plugs had spark, somthing to do with the governor inside the distributer. tell me on the 95 why did nissan put all that stuff in one unservicable part?
 

·
Registered
Joined
·
500 Posts
Same reason the retards (or geniuses, however you look at it) at X-Company in SomeAsianCountry designed VCRs and TVs to go out after a few years: so you buy another when it breaks. I remember back in the 80s when things were built to last. I have a VCR my parents bought in 1982 that still runs to this day. I'm 20 years old and that thing's almost as old as I am.
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #11
Get new platuim spark plugs. NGK Platium i think, Maybe crossfires dunno if they will fit. My Car idles at like 1- 700 even as low as 600. I was told to replace my spark plugs and i need a tune up.
 

·
Registered
Joined
·
125 Posts
UnderDog said:
Same reason the retards (or geniuses, however you look at it) at X-Company in SomeAsianCountry designed VCRs and TVs to go out after a few years: so you buy another when it breaks. I remember back in the 80s when things were built to last. I have a VCR my parents bought in 1982 that still runs to this day. I'm 20 years old and that thing's almost as old as I am.

Whoa!!!!! 20 year old VCR lol. COOL
 

·
Registered
Joined
·
500 Posts
It's a Zenith. The whole case is made out of steel and it weighs about 20 pounds or more. It's a beast. It's like lugging a mid-tower computer around.
 

·
Icy Hot Stunta
Joined
·
2,366 Posts
check your throttle position sensor. Also check to see if the air regulator valve has been installed correctly when the turbo kit was made.
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #15
The Main Event!!!!

Well I'm gonna be checking this weekend all these remedies.

1. Air Flow Meter?
2. Vaccum Hoses?, Maf Meter?
3. Throttle position?, TPS?
4. Air Regulator Valve?
5. Running rich?


Lets get ready to rumble. I'll get back to ya'll to see what fixed it. Most likely thise weekend. I appreciate you guys for helping out.
 

·
Hang out wit yo Wang out!
Joined
·
546 Posts
You said you bought the car right? Did you test drive it first, cause someone might have sold you a turbo lemon!!!
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #17
Re: The Main Event!!!!

GOGO47 said:
Well I'm gonna be checking this weekend all these remedies.

1. Air Flow Meter?
2. Vaccum Hoses?, Maf Meter?
3. Throttle position?, TPS?
4. Air Regulator Valve?
5. Running rich?


Lets get ready to rumble. I'll get back to ya'll to see what fixed it. Most likely thise weekend. I appreciate you guys for helping out.

I had the same problem with my 96 gxe turned out to be the IACV
Idle Air Controle Valve part ran me 175 from nissan replaced it and i haven't had a problem since.
 
1 - 17 of 17 Posts
Top