Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Hi all:

Well I was driving normally and the A/C stopped working. These are the symptoms:

-A/C button turns on (shows blue light)
-When A/C button is turned on I can hear the (pss), I guess is the compressor being turned on
-There is no air coming from the vents, not even when the A/C button is off
- I already checked the in-cabin fuses, and also the fuses under the hood, I checked them with a volt meter and the readings are 0 or 0.01-2
- I tested the only relay that said A/C by switching it with one of the antitheft relays (an identical one) and still no luck. Also when checking the ends of these relays the reading was 75ohm which I believe means that the relay is in good shape.

What else can I do to narrow down the problem??

Appreciate your help,

-Christian
 

·
Registered
Joined
·
4,208 Posts
Try the hi setting.. the resister fails and the lower speeds don't work....
Check your compressor is turning. Look for the center hub of the pulley to be turning ( double check by turning it off for a while then on.)
 

·
Registered
Joined
·
39 Posts
Discussion Starter #5
Tried the high setting and still does not work.

Today I drove in the highway with the A/C button on I had some COLD airflow, probably the air coming through the system due to high speed created this effect. I believe the fact that the air was cold means the compressor is fine, I guess. So it may actually be the AC fan.

Any easy way to test this fan??
 

·
Registered
Joined
·
39 Posts
Discussion Starter #6
Well I checked all the electrical parts and they were all good, switch, resistor, fuses. There was also current coming from the cable that delivers voltage to the blower motor. So I ordered a used one at my local junk yard and replaced it and voila!! My A/C is blowing again!! The FSM is an awesome tool!!
 
1 - 6 of 6 Posts
Top