Nissan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
New to forum I have a 98 Sentra XE 1.6 5spd. The a/c is not working. I had a friend of mine checked the 134 and it is fine, he had his gauges on and the copmpressor would not kick in. He checked the relay and jumped it past that the compressor came on and the high pressure kept going up. He shut it down at 450 before it blew something. We checked the fans (one not working replaced) and replaced the relay and jumped the switch on top of the dryer over still not working. I replaced the blower resistor thinking that maybe had something to do with it. When the compressor was on it got cold inside just had to shut it down before it blew. Any hints as what to replace or try next. My friend did not have any other clues as to what might be wrong. I have a 95 sentra GXE that we are swapping parts to try and figure out what is wrong. We cheked the relays, fuses, switch in dash also.: confused:
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
OK I guess nobody has any ideas either, if so please comment. My next step is to take to shop and pay big bucks I guess.
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,239 Posts
what is the pressure when cold and off ?
if its not over charged and its too high a pressure then there is a blockage.
I haven't seen this for years, my Pontiac had an expansion valve that had a brass screen and this clogged up with crap, causes very high pressure, the blow off valve let go and dumprd the freon. This was R12 and the blow off was set at about 450 lbs, R134A is hgigher.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Low side pressure was 80 with car off. I dont know where the expansion valve is? The ac will not turn on as is, Maybe too much pressure in system. We jumped over the relay to make sure compressor was working. We also had a jumper wire over switch in drivers side front above silver canister(?) I replaced the switch in dash just to check that. Just trying to avoid mechanic bills.
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,239 Posts
I dont think our cars have an expansion valve, will check the FSM.
My point is that its either overcharged or got a blockage (assuming the fans are running)
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,239 Posts
yes we have an expansion valve, but your first issue i getting it to turn on
80 is fine, the dual pressure switch should be on.
If you dont have an FSM download it at PhatG20.net
There are circuit diagrams, you need to check the dual pressure switch make sure its good, ie closed.
See HA49, ie in my 97 FSM
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
OK the low side was around 40 when we jumped compressor over, the high side kept climbing till we shut it down at 450. The other switch we jumped over was the dual pressure switch above the receivcer dryer. I got the fsmbut I am not sure what the expansiopn valve would be called? Thermal protector, thermal control amp, dual pressure switch? I will keep looking at fsm.
 

·
Registered
2018 Nissan Pathfinder SL
Joined
·
4,239 Posts
The dual pressure switch may not be on at 40, thats above spec but a bit low. check it with a meter.
Its called the expansion valve and is before the evaporator.
Please understand i am saying i had this expansion valve problem on an R12 system, it may be the expansion valve or another component causing a blockage.
BTW the safety blow-off is set at 540 lb/sq in.
 
1 - 8 of 8 Posts
Top