Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hello all
I’m new to this website. I have A 97 Maxima GLE. 117,000 miles on it. It’s my Finance’s.She bought it in 2000. The check engine light just came on. The codes are telling me that it’s the EGR valve, O2 sensors Bank 1 and 2 and the knock sensor. Is there one of these issues tripping the computer to read all of these. I have no problem replacing any sensor but I don’t want to replace one to find out it wasn’t the one tripping off the computer. Her ex supposedly took care of this car but I replaced the air cleaner and it was so damn dirty I Can’t see this to be true. Yesterday I replaced the plugs with NGK platinums and replaced the PCV valve. My girl always ran 87 Octane thru it. I have been reading threads saying this is not good. Someone has told me to start with the 02 sensors first. Do you guys/Gals agree? So far in the last 2 years I replaced- New Starter, Alternator, belts, axles, battery, plugs and pcv valve. I don’t mind fixing this car up. It’s a Great looking car. I just want to fix what needs fixing not wasting my money guessing.
Also the exhaust is banging around the bottom on the Car. I'm going to have this replaced. Do you recommend a muffler or do I go with the stock shop muffler? This car is just used as a regular everyday car.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2 (Edited)
check up

Hi people
I replaced the plugs and the pvc valve, reset the computer . I drove the car for a week then the check engine light came back on. Except now, I only have two codes, EGR valve and Knock sensor. I just ordered a knock sensor for $122 it's a standard. I read that these cars just go thought theses sensors and if I replace it, I will eventually notice an increase in performance once the computer learns to advance the timing. Well, no one gave me any type of help so I will keep posting just in case someone else is in the same situation. The plugs were NGK platinums. like 2.98 a piece. The two O2 sensor codes are gone. Two down ,two to go. I plan on installing the new knock sensor and cleaning the EGR Valve. I'll keep everyone up to speed.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Gasp pump accuracy

One more trick since we are all getting raped across the coals on gas. Here is an easy way to make sure your favorite gas station is pumping out the right gallons per Dollar. I have heard of gas stations prices vs. gallons being off. I'm from Philly but this happened in GA. Easy math. When filling up at what ever price per Gallon... Let’s say in Philly it’s 3.85 a gallon as your filling, stop at 10 Gallons for a second, check the price. The price should be $38.5 $3.85 a gallon X 10, if it's more then 10 X per gallon then your Station's pumps are off. Whether it's on purpose or not, you decide but this is a way as your filling up to make sure the gas station and the price all coincide.
 

·
Registered
Joined
·
10 Posts
im not sure why the o2 sensor(s) code would have just gone away. that is unlikely.

with both your foward o2s dead, and the knock sensor, you must be getting like 16mpg.....

the first thing i would do is make sure those o2 are operating properly. you can take your car to a dealership and have them plug it into the Nissan consult (they should NOT charge you). it will tell you what kind of signal they are sending.

second, the knock sensor. you can do this yourself with the aid or a girl or small child (with small hands)

wait till the engine is cold, and have this woman/child reach down into the IM valley with a wrench. get it on the head of the KS bolt (i think its a 10mm, could be 12). if the KS has never been changed before, the bolt will be very hard to undo.
get a prybar or something and pry the wrench in the correct direction till the bolt comes loose. the rest is cake.







and the new one

 

·
Registered
Joined
·
3 Posts
Canister purge solenoid

What’s up.
I have a 1996 Maxima and a few years ago, it threw the same codes. One for an EGR valve, and one for the knock sensor. Just like you, I spent the money and replaced them both. Obviously, this didn’t fix the problem. I then decided to ignore the trouble code and do some investigation. I started at the canister which is located under the left rear (drivers’ side) side of the car. It looks like a big box. Attached to the front of the canister was a little solenoid with two bolts, one pigtail, and a vacuum hose. It had a little valve in it that appeared to be frozen so took a chance and replaced the solenoid. I believe the correct name is canister purge solenoid. After that, I drove the car for a while and the code reset itself. I am sure you can reset the computer yourself but I wasn't having a lot of luck doing it that way so I decided to let it reset on its own. I am pretty sure that this is your problem. Trouble codes sometimes only show you the sensors that were triggered by the actual fault, so they are not always accurate. I hope this information helps.

Kevin
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6 (Edited)
egr Valve and Evap Circuit malfunction

Thanks Kev

The knock sensor code is gone after I replaced it. The O2 sensors codes are gone after I replaced them. Now I was left with just the EGR valve but recently P0446 has appeared. It shows as pending? What ever that is. I'm in the process of trying to clean the EGR valve. I just broke it free from the block tonight. It was on there pretty tight. Does anyone have any ideas on how I should clean it? I have read a few threads but I'm open to more input.

As for the Evap code P0446. I'm reading it could be the Gas cap or the Evap canister valve. Is this correct? and if so is the canister located under the car? Because I have seen a Evap purge valve located on top of the manifold.

When I release the Gas cap I can hear the pressure release so I would think thats ok. Any input would be great. Thanks everyone.

Also this could be coincidental but every once is a while I just noticed very rarely the smell of gas in the car for a traffic light then it's gone. I'm not sure if it's coming from my car or not.
 
1 - 6 of 6 Posts
Top