Nissan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey I have a 95 Nissan Pathfinder. About a month and a half ago I took it mudding and then accidently sunk it pretty bad. I've been trying all sorts of things to fix it. Right now it runs better than it did, but when it's still cold if i press the acelerator all the way down it boggs and trys to die. So far I've changed the spark plugs a few times, changed the oil, added additives and changed the oxygen sensor (that made the most difference). Does anybody have any idea what the problem might be? It has a 190,000 miles on it, and the check engine light recently came on (actually before I went mudding). Do you know how to check the codes on a 95. I don't know if it has a plug for OBD I and if it does where is it...or how to check it otherwise...thanks appreciate the help!
 

·
Moderator
Joined
·
3,553 Posts
Did you suck water into the engine? Try cleaning your MAF sensor. If the ECU got wet it'll screw things up ROYALLY. It's under the passenger's side seat on the floor. There's a link at the top of the forum on how to check ECU error codes...
 

·
Registered
Joined
·
41 Posts
'95 Pathfinder

--------------------------------------------------------------------
Just a possible suggestion .... Mice in the Air Filter box ?
-----
A mouse ran across the floor as the engine was running lousy up a hill and the cab smelled funky, ..... Frickin' Mice Invasion !
Trapped two of those stinkers today after cleaning out their nest in the air cleaner.
How did they get thru the firewall into the cab ? Another Nissan Pathfinder mystery.
------
Note: I'm leaving the Exhaust Manifolds studs busted for another 10K mi and "gas" those pesky pricks out.
------------------------------------------------------------------------
 
1 - 3 of 3 Posts
Top