Nissan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
I hadn't driven our 95 Pathfinder at night for a very long time. The weather turned bad and my wife drove it to work. I noticed it had no tail lights or dash lights. I checked the fuses below, on the passenger side, and they are all good. I looked under the hood for another fuse (possibly), but found none. I did find 2 fuses for the headlights under the hood. They are in with relays on the passenger side on the fender.

About 6 weeks ago, I replaced the battery terminals, which were highly corroded. Maybe this has something to do with the problem. Anyone have any ideas? Is there another fuse box somewhere?

Also, I drove it last weekend and found out that the key will not unlock the rear glass window. Could this be related? The key will unlock the hatch. Thanks.
 

·
Registered
Joined
·
354 Posts
i am not sure about 95 but for r50, tail lights and all dash lihgts are on same fuse. I dont know why this is so.
 

·
Registered
Joined
·
116 Posts
Discussion Starter #4
Is the fuse between the switch and the lights? I would suspect it would be. If there is no power at the fuse junction, I guess it would just about have to be the switch. Does the round end snap off somehow? It is on the blinker assembly. I jacked around with the switch last night thinking I may get it to come on, but nothing. Thanks.
 

·
Registered
Joined
·
116 Posts
Discussion Starter #7
Thanks. This worked great and was very easy. I removed the switch and cleaned it in the house since it is so cold out. I now have dash lights and tail lights.
 
1 - 7 of 7 Posts
Top