Nissan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
hi all
ive got a 94 vg30e pathy that has some running issues atm
when it starts (which isnt all the time) it idles at about 1500 rpm and it ant smooth(but it ant missing its ass off neither) it also smells like it is over fuelling heaps (also using heaps of fuel) also at time when driving it will have a bitch, when i cant accelerate Easley it idles kinda then when i accelerates it almost dies so i fead more throttle into it then it starts to pick up n will rev fine over 3500 rpm so its is kinda a pain when i have to limp home like that also spews black fuely smoke makes ur eyes water real pain so I riped the seat out n checked 4 codes I found code 13 engine coolant temp sensor and that’s all I also tested the tps using the ecu and dint get a response on the red led….. But if it wasn’t working I thought it would throw a code. I also took the thermostat out cause of heating issues but now it runs under operating temp so that may have something to do with it so ive got a new thermostat and gasket 4 it and ima get a tps 4 it and see where that leads so any more ideas on this would heap me heaps chears
 

·
Registered
Joined
·
104 Posts
Hi, this really isn't a coolant issue from what you said. If it does run too hot or too cold, then yes get that fixed, it can lead to issues later down the road or decrease performance.

I would be looking the spark plugs, the distrubitor, and the such.

I had a simular issue recently, and I only had to change the spark plugs (something that is a pain to do in these engines) and also did the fuel filter.

I do think yours is differnt though, but maybe not.

Do you lose any oil or anti-freeze?

Do you know the last time the spark plugs where changed, the distubitor? How about an oil change.

Also remember, 94, you have an OBD 1 system, and if it is anything like the 92 I have, it is very simple and does not check a lot of things. Ours was miss firing like crazy (up to 3k rpms) and it never gave a code.

You may want to visually inspect the spark plugs, the wires and the distrubitor.

And black smoke means the engine is running rich (getting too much fuel).
The only time I saw black smoke is from what I expect was bad gas, it didn't smell right, and as soon as I put add gas from a different place it clared up - this was also the reason for changing the fuel filter).

I'm also sorry, at the moment it is hard to read through all your problems with how you wrote them out, so I did jump around a lot and I may have missed a few things/
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
chears mate 4 ur help
i changed the tps and mass air flow today as i thought thay were the problem to the over fueling problem when i changed them nothing happend....
i pulled out the spark plugs and found thay were fouled like a mofo also the dist cap was also fouled up with crossion i replace 3 spark plugs (wat i had at the time) then i got it to start it ran ok but had a miss fire
i have no i dear on the service history on the vehicle as i just got it a few months ago so ive got new plugs , leads, dist cap, rotor botton, oil,air and fuel filters coming 4 it on the weekend
chears for your help
 

·
Registered
Joined
·
104 Posts
your welcome, see how the new parts work. The spark plugs probably get forgotten a lot on these engines because of the location. The spark plugs, when they get bad enough do cause some pretty bad issues, on ours, it had a slight miss fire when it was cold, and it would stale, but once they were changed it worked a lot better.

Hope this fixes it for you
 
1 - 4 of 4 Posts
Top