Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1

I did a search on this and came up with mixed problems and solutions. Ok, this started about 6 months ago, while driving around for a while then coming to a stop, the brake/charge light would come on and there was a buzzing coming from the fuse panel area. It was fine until recently when it started happening again. I changed out the alternator and everything was good until a few days ago, when driving with the a/c, defroster and lights on the charge light comes on very dim but when I take my foot off the accelerator pedal it goes off. It seems the fast I accelerate, the more it comes on. Could this alternator be bad also? I cleaned the grounds on the battery cables but didn't seem to help. I got the rebuilt alternator from pep boys, are these crappy?

Thanks!
 

·
Nissan Technician
Joined
·
826 Posts
My '94 Sentra LE does the exact same thing! I'll drive it hard and the battery light will illuminate brightly until I let off the gas. This is a sign of an alternator starting to go bad! I've been too lazy to replace mine though...:loser:
 

·
Registered
Joined
·
734 Posts
i have not found a "good" re manufactured alternator from any auto part stores yet.
i went through 4 in 3 months, then i went to a pull-a-part and searched through all the sentras and found a rebuilt one by NISSAN. been running great for over a year now. you have bad alternators.
 

·
Registered
Joined
·
6 Posts
Yea, Mine did this last year....i blew 4 alternators in 2 months! I got rebuilt alternators from Auto Zone. In the end i got a brand new one... Worked like a charm...
 

·
Registered
Joined
·
734 Posts
most oem parts are worth the money. but damn who can afford them!:jawdrop:
 
1 - 6 of 6 Posts
Top