Nissan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi I am new here, I was looking for help in diagnosing the problem with my 93 Nissan pu 2.4L.
I was on the off ramp stopped at a red light when my truck died. Tried to start is but it just cranked.
Towed it home.
I am embarressed to say that I did not do a good job trying to figure this out. I have been working many hours and getting home late, so I thru alot of new parts without trying to figure this out.
I checked for spark at the distributor end of the coil wire against ground, at first had weak spark now has no spark when I check it only when I quit cranking the engine it sparks once.
I checked the resistance of the coil and it was in specs with the repair manual that I have and resistance was identical to a new one. Later I installed a new (dont ask)
I checked the 4 wires leading to the distributor, I took the connector (the one infront of the head) and put a copper wire in each terminal and connected it back together with the wires sticking out so I could check them for voltage. with key on one wire had 12 volts and one had 5volts I think and the other two had nothing. With the key on I turned the distributor (I took in out of engine) to see if the voltage fluctuated, it did nothing, so I replaced the distributor thinking the crank sensor was the problem, it was not the problem.
Lastly I checked for resistance at the a and b terminals of the module/power transister mounted under the coil it was ok, but I ended up trying a new one anyways, that was not the problem
Oh and I installed new cap and rotor and wires premium brand.
I hope the coil wire is supposed to have spark when you crank the engine.
Can any one help? Oh I also checked for voltage at the + terminal of the coil plug and it has 12v with key on also checked fuses.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4 (Edited)
thanks for answering guys,
the manual that I have is a chilton 89-95 pickup and pathfinder repair manual.
I checked the codes; in mode III I got 55 according to the manual this means that everything is ok. I checked the throttle switch in mode IV and it checked out also.
The fuses that I checked were the ones under the dash next to the driver door. I have not checked any relays or fusible links. Do you check them by measuring the resistance?
 

·
Hardbody Freak
Joined
·
2,673 Posts
no,
a circuit tester.

it is a screwdiver looking item with a light in the handle and a wire with an aligator clip.
the clip goes to neg and the other end is probed into the circuit pathway to check for power.
 
1 - 8 of 8 Posts
Top