Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
The car has 92k miles on it (never have transmission flush done - bad mistake). Tranny has been slipping for a while (mostly between 30-50 mph). But at least I was able to accelerate slowly (while slipping). Since last week, the tranny slips after the car reaches about 20 mph. It's like the car is in neutral after it reaches 20 mph. No acceleration at all after 20 mph. I have to put the car to "2" (2nd gear) to drive. Do you guys think i need a transmission rebuild ?

1) how much parts+labor does a rebuild cost ?
2) would that be cheaper to get a tranny from junk yard and pay labor for installation ?

KA24E does not have transmission filter. So would a transmission flush help solve the problem ?

Thanks !!
 

·
Registered
Joined
·
2,376 Posts
mf915 said:
The car has 92k miles on it (never have transmission flush done - bad mistake). Tranny has been slipping for a while (mostly between 30-50 mph). But at least I was able to accelerate slowly (while slipping). Since last week, the tranny slips after the car reaches about 20 mph. It's like the car is in neutral after it reaches 20 mph. No acceleration at all after 20 mph. I have to put the car to "2" (2nd gear) to drive. Do you guys think i need a transmission rebuild ?

1) how much parts+labor does a rebuild cost ?
2) would that be cheaper to get a tranny from junk yard and pay labor for installation ?

KA24E does not have transmission filter. So would a transmission flush help solve the problem ?

Thanks !!
If you can, try the flush. otherwise could be time for a rebuild. Almost sounds like the first gear clutches are bad...which would also affect reverse i believe. But if you can afford it (time and money) try the flush first....it can sometimes buy you some time.
 

·
Biru O' Kudasai
Joined
·
1,426 Posts
I agree with Gsolo try to flush it or at least change the fluid by draining the trans and torque converter. But it sounds like the valve body is leaking fluid pressure internally.

Troy
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
KA24Tech said:
I agree with Gsolo try to flush it or at least change the fluid by draining the trans and torque converter. But it sounds like the valve body is leaking fluid pressure internally.

Troy
Thanks... Brought it in to a transmission shop for repair. $850+tax. They said they changed clutches and bands. Will pick up the car tomorrow.
 

·
Sentra Specialist
Joined
·
1,902 Posts
mf915 said:
Thanks... Brought it in to a transmission shop for repair. $850+tax. They said they changed clutches and bands. Will pick up the car tomorrow.
That's a really good price for a tranny remove/rebuild/reinstall. I replaced my '90 U12 tranny about 6 years ago and it cost me $1,500 for the reman. and I had to put it in myself. :(
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
blownb310 said:
That's a really good price for a tranny remove/rebuild/reinstall. I replaced my '90 U12 tranny about 6 years ago and it cost me $1,500 for the reman. and I had to put it in myself. :(
They only replaced 3rd clutch and 2nd band. The guy offered me two other "packages". $1200 (put in more new stuff), $1400 (more and more new stuff). I just took the cheapest option $850 to get the basic stuff fixed. So far so good. I think i have better mpg now !
 
1 - 6 of 6 Posts
Top