Nissan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I just bought a 91 sentra xe with a manual tranmission a few weeks ago. When I bought it it had a transmission fluid leak, which was coming out of the drivers side axle. Since both of the cv joint boots were torn, I figured I would replace the axle and seal at the same time, fixing the leak. After replacing the axles, the leak continued, but it was a slow leak, so I figured I would just check it often and make sure it was full on fluid.
On monday I checked the fluid I must have put about a quart in before it was full again, and looking under the driveshaft I could see it dripping out nearly as fast as I was putting it in. I took off the driveshafts again, replaced the seals again, since it seemed like I put them on wrong, and again, still leaking. So, my question is what am I doing wrong? Could I have somehow hurt the transmission replacing the seals? What do I have to do to fix this leak?
 

·
Registered
Joined
·
734 Posts
make sure your not putting them in too far or not far enough. lube the seals before you put the driveshafts in, so you dont damage the seals. are you checking to see if the seals make a good seal with the driveshaft out? i know they have several different sizes.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
It seems like the seals are making a good seal. I'm not sure its actually leaking from the seals, but instead maybe its leaking from actual hole where you put the driveshaft in. Is that a possibility? How far do they need to go in?
 

·
Registered
Joined
·
734 Posts
i always make sure the outside of the seals are flush with the lip on the transmission.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Alright, I discovered I had been buying the wrong seals. I'm not sure what one's autozone was selling me but they were definately way too small. I went down to the nissan dealership and picked up a set of proper seals (they cost less there too :) ) Thanks for your advice, it actually was very helpful.
 

·
Registered
Joined
·
734 Posts
glad to hear you got the problem solved! :)
 
1 - 6 of 6 Posts
Top