Nissan Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Hey guys,

I just bought an 89 HB with the Z24 in it. When I say just bought I mean as in this past Saturday. I can push in the throtle pedal about 1/4 to 1/2 down then the engine hesitates and I have to let off the gas to keep going. As long as I ease on the gas and hold it about 1/4 to 1/2 throttle I can drive anywhere I need to go. The cap, plugs, rotor, and wires have been replaced. Anyone have any ideas? Thanks in advance
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
PROBLEM SOLVED!!! I changed the secondary coil and now all is good!!! ZANEGREY... YOU ARE THE MAN!!! Thanks bro!!
 

·
Registered
Joined
·
11 Posts
pardon me for my innocence i also have the same problem... where do i locate the SECONDARY COIL? and when you say "check" how am i suppose to do it and what are the things that i should keep my eye on? TIA
 

·
Registered
Joined
·
706 Posts
The exhaust side coil! Put a timing light on the coil or spark plug wire! Coil is on during light and medium throttle, off during deceleration or WOT!
 

·
Registered
Joined
·
185 Posts
My truck was running fine before the tune up and now I'm having this same problem. Everything has been changed, wires/plugs, cap/rotor, can this cause and older secondary coil to go bad? I replaced everything back to original and still had the same issue so I know the new parts are good. Thanks for any help on this.
 

·
Hardbody Freak
Joined
·
2,675 Posts
the second coil would not cause it to idle incorrectly..
regap the plugs to .32 and repost..

most times on the 720's you can reroute the fuel pressure regulator vacumn to a manifold source to fix the idle..

but regap the plugs first...
 
1 - 12 of 12 Posts
Top