Nissan Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
hey everyone, i have looked thought this whole site and only found one post that might help me! i have a 89 240sx and it seems like theres no gas getting in the engine.. my sisters man had it running and i did to.. he also had it running with that spray stuff, sorry cant spell what its really called but i no its not good to use it. but the fuel pump is good and the plug wires are on right. and the spark is ok i guess... its red spark and not blue? i dont no if thats good or bad but its started and idled and revved... so if anyone can help thxs. i need to no what to check and d*mn i just need help thx!
 

·
Sup Mod keeping the peace
Joined
·
7,219 Posts
Your thread has contradictions; you're saying you had it running, your sister's friend had it running, then after your testing, you had it running again.

Which is it; is it running at all or not?

If you think the motor is not getting fuel, replace the fuel filter. An easy way to test the fuel pump and filter is to disconnect the fuel hose from the top of the fuel filter and insert a long length of spare hose into the top of the fuel filter with the other end draped over the fender going into a catch can placed on the ground. Now turn the ignition key to the run position but DO NOT START THE ENGINE. You should see fuel going into the can at a good rate for several seconds.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
we got it started and running then it would idle then stall... now it wont start at all.. but there is gas getting to the engine so...idk it seems like its not gettin g in the engine! and he thinks the mass air flow senor is bad!
 

·
Sup Mod keeping the peace
Joined
·
7,219 Posts
If you suspect a bad MAF, then unplug it and the engine should start up. However the engine speed will not go above 2,400 rpm because it will be in fail-safe system operation.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
im going to try that tomorrow cuz i got to bring the car home and its at my friends... but thats what my sisters bf is saying it is... the car just wont start and its making me mad... we tryed getting it to run today and it will only stay running if you keep sparying aether in it... thats the only way it stays running! and its bad to use that crap!
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
ok.. i tried it and it sounded like it wanted to start for like a sec. and then i tried starting it again and i got nuttin!
 

·
Sup Mod keeping the peace
Joined
·
7,219 Posts
Well, then it's not a MAF issue. It's probably a fuel delivery problem. Have you gone through the recommendations that I had first posted?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
its runs! i drove it. it wont go past 2400 rpms... do it stalls alil while after its running... i will be getting a MAF soon... do you no why it would stall? or is it cause theres no MAF?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #10
ya.. i no..rogoman told me that... now i would like to no if the stalling is because theres no MAF. (car parked) and is it bad to drive it like that...well i think it is. but j/w? will it run lean or rich without the MAF?
 

·
i'm an asshole
Joined
·
1,859 Posts
i don't really understand, cause you're saying it won't go past a certain rpm, but it doesn't matter if the cars moving or not, it will still cut off once you hit that certain spot. is it just stalling by itself idling? that may because of a vacuum leak. and i'd say its more unsafe because the ecu isn't reading any airflow.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #12
ok it wont go past 2500rpms and when it gets to 2500rpms it bogs...ok... thats not the problem... i no that post to happen cause it doesnt have a MAF. but the engine will only run for like a min. till it stalls. so i was wanting to no if it stalls because it has no MAF for right now.
 

·
i'm an asshole
Joined
·
1,859 Posts
i don't think it should cut off just because you don't have it on. i talked to a girl from georgia who drove from atlanta to north carolina with no MAF on her SR.
 

·
Sup Mod keeping the peace
Joined
·
7,219 Posts
its runs! i drove it. it wont go past 2400 rpms... do it stalls alil while after its running... i will be getting a MAF soon... do you no why it would stall? or is it cause theres no MAF?
If the MAF is unplugged, it should still idle OK. For the stalling problem, check the following:
- IACV may be dirty or needs adjustment.
- Air regulator may be bad. It provides a fast idle when the motor is cold.
- Fuel pressure regulator may be bad.
- Weak ignition.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #15
my sisters bf said something about the spark plugs have weak spark. the spark is red. is it post to be blue? i will check the other stuff tommorrow
 

·
Sup Mod keeping the peace
Joined
·
7,219 Posts
The spark should have a bluish appearance. The coil or power transistor may be marginal.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #18
ok i have a MAF now and it started.. and when i gave it gas it stalled out... so im thinking it might be weak spark... tell me what to check please.. and i kinda no nothing about 240's so tell me where the part is to check and thanks for all the help now
 

·
Registered
Joined
·
12 Posts
Its probably not the MAF, I drove my sentra around for like 4 days with a shot MAF, it just had no power after around 2500 rpms (as a couple guys have said). But the easiest way to tell if your MAF is bad is if it does this and also makes like a loud roaring sound through the intake, almost like its jumped timing or simething and is exhausting through the intake.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #20
i no its not the MAF. cause i just got a new one..sooo....ya.... but im checking the vacuum lines and clean the Air regulator... and i have to check the spark again today...
 
1 - 20 of 28 Posts
Top