Nissan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
i have a 88 hb with the se v6 engine it has 180,000 miles on it and just the other day it knocked when i started it,i turned it off and then started it again and it was fine,since then it has happened a couple times but it always goes away after i turn it off,is this just piston slaping?any ideas would be great i would hate to see my spirit of 88 die on me..Thanks Patrick
 

·
Registered
Joined
·
706 Posts
Stop using those cheap ass oil filters switch to WIX, NAPA, MOBIL 1, K&N, all those mention are really WIX filters. Fram doesn't make good filter they've got anti-drain back valve problems.
 

·
Registered
Joined
·
120 Posts
also check the oil pump, open the oil cap when motor is running, if oil is spitting out its good, if not its bad
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Well i used a napa gold oil filter last time i changed the oil,but i could be defective since this didnt start till i changed it but i also opened the oil cap while it was running it was not really spiting at me but it seems to run fine and it doesnt need to warm up for the sound to go away,but im taking it apart wendsday for some belt maint so i might just replace the filter again and see what happens
 

·
Registered
Joined
·
120 Posts
oil pump is bad, i wouldnt run it with it not getting enough oil pressure, you could serverly damage the internals of the motor. trust me, im a certified mechanic. you can get an oil pump for about 75-90 bucks, and its very simple to change out, and while you're at it change the oil pressure switch (6-9 bucks)trust me. you should have oil comin right up in your face, and when i did my timing chain, and started it it ran fine but oil was not comming up, so i fixed that problem before it got worse.
when changing oil pump make sure the punchmarks all line up.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
thanks man im gonna be working on it in the morn as long as its not snowing,but in the service manual it says to remove the oil pan is it safe to assume the pump is inside of the pan sorry i usally work on bikes but im gonna run down to napa and see what they have for me....
 

·
Registered
Joined
·
706 Posts
IMO If it were the pump it would be permanent! Sounds like an open anti drain back valve found to be a problem on FRAM FILTERS!!!!!!
 
1 - 8 of 8 Posts
Top