Nissan Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
hey so i did an engine swap taking a 88 pathfinder engine and put it in my 87 kingcab. hooked it all up and it ran fine for three days around the yard. took out on the road once and it didn't feel right so checked some stuff over. hooked the injector wires back up and then fired it up and it was running fine for 30 seconds and then died and hasn't started since. have lots of spark. engine has lots of compression and changed the upper half of the throttle body and everything on it. tons of fuel coming out of fuel filter but nothing through either set of injectors that i've tried. will run if i keep pouring fuel down through the throttle body by hand. currently changin egr since it was clogged up but i still don't think it will work. any help with this is greatly appreciated. read something about accelerator pump could be toast but i've looked everywhere for it and i don't think this engine has one!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
i tried a new regulator already. didn't change a thing. new throttle sensor,new ficd valve,new air flow meter. basically changed everything on the throttle body. except for the vcv. but checked that and it seemed to have the same spring pressure as my other throttle body and it wasn't clogged at all. basically fuel is being delivered to the injectors and they aren't letting it through. but i tried new injectors and that didn't change anything. wiring is exactly as the book says. is there something else that tells the injectors when to release fuel. checked codes on ecu and all i got was that egr code so far.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
thanks. any idea what the supply voltage for the injectors should be? and also the location of the source wires and colors?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
ya i figured all the colors out up to the first plug from the injectors and then from there are 2 red/white and 2 ground wires. just need to know where they finally resurface in the truck so i can get make sure they aren't damaged at all and have full continuity.i'm figurin they run straight to the ecu but haven't checked yet. wiring diagram doesn't show where they connect to as far as i can see. thanks
 

·
Hardbody Freak
Joined
·
2,675 Posts
the 2 power wires for the injector merge into one wire in the service loop just 4 to 6 inches south of connector plug..

it has a brass crimp that brings the three wires together..
 
1 - 9 of 9 Posts
Top