Nissan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I just bought an 86 300zx, nice car but the radio won't power up. Its on a car with a digital dash and radio controls on the steering wheel. The radio head has an equalizer under it, I am sure it's OEM stuff. Is there a repair facality? Is there an replacement that has a cd changer that will fit and function correctly...Thanks for the advice and your time, LA
 

·
mmmmmm SQ
Joined
·
749 Posts
your best bet is to put a want ad in the classifieds here, and at other 300ZX forums. Most of the time people will buy aftermarket head units and have no use for their old one. I'm sure someone would be willing to sell it to you fairly cheap.

Can you get pictures of this "equalizer" or can anyone confirm that an 86 300ZX came with an equalizer? If I had to guess, I would guess that whoever owned this car before you was using the speaker leads to power the equalizer, which converted the high level inputs into RCA outputs and ran a stereo system.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
300zx radio

Punkrocka436 said:
your best bet is to put a want ad in the classifieds here, and at other 300ZX forums. Most of the time people will buy aftermarket head units and have no use for their old one. I'm sure someone would be willing to sell it to you fairly cheap.

Can you get pictures of this "equalizer" or can anyone confirm that an 86 300ZX came with an equalizer? If I had to guess, I would guess that whoever owned this car before you was using the speaker leads to power the equalizer, which converted the high level inputs into RCA outputs and ran a stereo system.
Yes I can take a picture of it tomorrow, it's all built into the panel with the control head...the same guy owned it for 18 years and says thats how he got it new...beats the hell out of me, it came on once and everything worked for a few but then it went off....I read something about putting a tape in it and making it power back up??????
 

·
Banned
Joined
·
3,554 Posts
check the fuses
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
♣AsleepZ♣ said:
check the fuses
I did, looked fine, will test again with a volt meter in the AM....the lights on the heater control are dim also, the man i got it from said someone tried to fix it so you never know what's behind there loose or disconnected, but it did power up once,,,do you know how the front panel of the radio comes off...also the guy from the other post asked me about the equalizer under the radio...I am not familiar with all the different Z car sound systems options to realy tell you what's in the car besides and am/fm cassette with that equalizer under it,,,,it all looks factory
 
1 - 5 of 5 Posts
Top