Nissan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello, since yesterday my nissan x-trail twice simply shut off while I was waiting at a red light and the service engine soon light went on!

I was both times able to re-start it... not without a little problem. Could this be something with alternator or if you have a few ideas.... you're welcome to share.

tks
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
Just thinking, could it be the gas filter.. since it stops only when i am at a complete stop because when I'm on a roll.... it goes fine!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
never been wrecked , tuned up every 5000KM, and I filled up at a good place... I'm also thinking gas pump or gas filter.... but more gas filter, because I'm thinking if it would be the gas pump, it would stop even when I'm going, not only when stopped.. It's being checked tomorrow morning, I'll keep you posted.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Finally, it's the crank shaft sensor that is defective, so the piece is approx 50$ cad + work, it's not much of a problem! Thanks for reading my problem everyone! See ya next time something happens with my beloved x-trail. lollllllllllll
 

·
Registered
Joined
·
172 Posts
Thanks for posting what was causing your problem. It may help the next person with this issue. How many km were on your XT?
 

·
Registered
Joined
·
1 Posts
Just read now 10 years later, and i find the information helpful. My X Trail has been behaving lile this
 
1 - 8 of 8 Posts
Top