Nissan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello ALL,

UK X trail, registered August 2005.
I will try to describe the problem as clear as possible:
Problem
I am accelarating on the 4th gear, increasing revs from 2000 and on the 3500 revs the car suddenly stalls, freeze, not accelarating! The car will not accelarate until i leave my foot and push the pedal again. There are no faults or engine lights on.

This is not happening always. It is always when am driving in motorways (since it only happens on highspeed gears. The problem appears say once every five times that i accelarate in the range as describe above. It is not happening on 2nd/3rd gear (very very rarely on 5th/6th gear).

The problem goes back in December 07. NISSAN dealership thought it was the fuel filter (Dec 07), they changed it. Then in Feb 08, they have changed the Turbo control valve (without their system telling them about any faults), problem still there. A week ago, i took the car back and supprisingly i was told from them that their system came up with a fault, it was the Turbo control valve ! Obviously, they did change it and guess what? Problem still there!
I AM DISAPPOINTED WITH NISSAN DEALERSHIP. How can an engineer change the same part within 3 months and be proud that he found the problem ! I was sure from the moment i drove the car out of the nissan service area that it would do the same problem and it did!

Can someone guess what is wrong with the car, since NISSAN cannot ....
Can you tell from the car reaction what could be the problem?
Is anyone out there facing the same problem?

PLEASE need your help!
Thanks,
Andy
 

·
Registered
Joined
·
3 Posts
I had exactly the same problem with my Nissan tino 2.2 dci 54 reg (same engine) and it was one of 2 at my dealership that exibited these symptoms when pulling hard up a bank in 3 gear, it was eventually traced to the turbo 'overrevving' and shutting down . the cure was a replacement turbo under warranty but the garages are reluctant to do that unless its a last resort due to the cost involved

Hope this helps
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
I had exactly the same problem with my Nissan tino 2.2 dci 54 reg (same engine) and it was one of 2 at my dealership that exibited these symptoms when pulling hard up a bank in 3 gear, it was eventually traced to the turbo 'overrevving' and shutting down . the cure was a replacement turbo under warranty but the garages are reluctant to do that unless its a last resort due to the cost involved

Hope this helps
Thanks for your reply miroku... Exactly as you said, they were reluctant to change anything that would cost them money and time..... its been going on for 5 months now....
ANYWAY, finally they did change the TURBO last Saturday (under warranty). So far so good !!! The car drives different as well. Lets see....
thanks,
Andy
 

·
Registered
Joined
·
2 Posts
Hi tiesto80,
I've been told about the same problem from a friend (IT X-trail 2.2dci),
It was the fuel filter, full of water!!!
In that case the engine failure lamp does'nt work.
I don't know if U gotta the same problem, but it's a good tips for everybody to clear the f.filter using the button on it.
Ciao
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
Thanks Angotred.... I will take your tip for the future....
Nissan thought the same, so they changed the filter first thing... however in my case was not that. They changed the turbo valve control twice !!!! Imagine how professional they are. An engineer takes a car like a robot, change the turbo valve control (as he was asked to do it) and does not look at the history of the car.... HOW ON EARTH a car would need to change the same part within a month.... At least they should look for what causes the problem instead of just changing a part....
ANYWAY, touchwood, it appears that is all sorted now for my car by changing the Turbo... under warranty....

If anything comes up, i will update u.
Cheers,
Andy
 

·
Registered
Joined
·
10 Posts
The engine may need re-mapping, this is a common fault and is due to Euro 4 emissions. Nissan know all about this technical problem.
 

·
Registered
Joined
·
25 Posts
Any similarity to my problem http://www.nissanforums.com/x-trail/149961-xtrail-2-2-dci-2005-stutters.html?

I gather nissan will replace the turbo up to 5 years.. so am hoping this is the cause (or something simple like a split pipe). For me as the car is 2005 I don't think it's ECU

Fuel filter's a nice idea. Have to try that button (no idea where it is!)

What's frustrating is not having confidence in the dealer knowing what's wrong...
 
1 - 7 of 7 Posts
Top