Nissan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone,

I'm unsure what forum I should post this in as we don't actually cover this model vehicle.

I have a 2004 Nissan Avenir running a QR20DE and CVT. - model code is W11

Currently, my dash intermittently stops working. During New Zealand's recent summer it worked flawlessly (hot) however now winter is here a couple of weeks back when the real cold and rain hit the dash has stopped working. When the dash stops working my central locking also stops.

Hooking up my analyzer I get a fault code relating to CAN communication loss to the dash(I'm trying to think back on this so exact code evades me).

My thoughts are possibly a dry solder somewhere or bad terminal in a plug.
I do have a service manual but frustratingly it's all in Russian.so finding the correct wiring diagram and then being able to follow it is tough.

Has anyone struck this before or able to guide me to how the dash and central locking coincide with one another?
any other advice or guidance would be great too.

thanks a lot for all your help.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
So I did a little bit of work on it today. I have been pretty adamant it is the dash cluster itself causing the issue. so after checking all the plugs to the ECU and the transmission control module and finding nothing wrong there I moved back to the cluster and pulled it out. Once again everything looked fine. No dry looking solders or obvious corrosion. As I didn't want to pull the needles off the gauges which meant I couldn't see what was happening internally on the circuit board. I decided to just loosen all the screws and re-tighten them down in case there was something going on I couldn't see. I put everything back together and what do you know everything is working again....but for how long.
 
1 - 2 of 2 Posts
Top