Nissan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
its a struggle to actually start and keep my car running it will either die right away or run for a couple minutes the longest it has stayed on in idle was 15 minutes until the temperature gauge reached about the mid point, and today when i was running it it wouldnt stay on i had to gas it when it started to die to keep it running. As soon as the car gets warm it will either not start at all or give a little umf like it tried to start and no more. My dad has been working on cars since he was 12 and he thinks it might be the camshaft position sensor even though i just replaced it. While I have very shit knowledge of cars this one is actually my first car trying to learn about cars while fixing this one up. I would like to get more opinions on what others might think is wrong with it any help at all would be greatly appreciated even if your telling me that it is the camshaft and this post was a waste of time because my dad figured that out already.

edit* as soon as the temperature gauge is about the halfway point is when the car doesnt start
 

·
NF Mod/Nissan Master Tech
Joined
·
9,431 Posts
I believe the camshaft and crankshaft position sensors in these cars were recalled years ago. Aftermarket sensors aren't always reliable. Nissan has a "sensor kit" which has both of the sensors and is much cheaper than purchasing the two, separately. Perhaps the cam sensor is fine and it's the crank pos sensor, instead? I would be inclined to test the fuel pressure as it may be low and I have replaced several fuel pumps in 2002-2004 Sentras. If it is, the good news is that it is located under the rear seat and easy to replace; I can replace them in less than 15 minutes. It's best to stick with genuine Nissan fuel pumps. I would also check it for stored trouble codes. Another issue I've seen on these is bad head gaskets causing misfires and stalling.
 
1 - 4 of 4 Posts
Top