Nissan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
I recently bout a 2002 Nissan Altima s 2.5 it has 185,000 miles when I bought it I ran the codes because the service engine soon light was on it had codes for cylinder 4 misfire and bad oxygen sensors I replaced all 4 coils and put 4 new spark plugs on it and I replaced the 2 oxygen sensors cleared the codes and the next day the light was back on for oxygen sensors again so I replaced the catalytic converter cleared the codes again from day one the car starts perfect when its cold but if I drive it around town a little bit and kill it it wont start back til the engine cools off it also has a rough idle when u first start til u get it going good I burned up the starter once trying to get it to start so its got a new starter on it after I replaced the catalytic converter and cleared codes it came back on for system too lean bank 1 we thought the fuel pump was weak causing this so we put a new fuel pump on it still doing it its also getting awful gas mileage before I could go 100 miles on a quarter tank of gas now I'm luck to get 50 miles it has died on us twice when we are coming to a stop ran the code right then and it was the code for idle air valve I think cleared it and that code hasn't come back yet but we are at a lose while its hard to start and gets such bad gas mileage also about every 2 weeks we have to put water in it cause it starts running hot and its not leaking water out anywhere we are not sure where its going
 

·
Registered
Joined
·
3,193 Posts
Was that really one complete sentence?
 

·
NF Mod/Nissan Master Tech
Joined
·
9,504 Posts
Check for a bad head gasket by doing an engine compression test and a cylinder leak down test. When doing the compression test, make sure the engine meets the minimum compression specs as many of these engines were affected by the catalyst media breaking down and getting sucked into the combustion chamber.
 
1 - 5 of 5 Posts
Top