Nissan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
The AC has gone out on my Pathfinder. The shop I took it to says I need a new AC Control Head. This is a very expensive part from Nissan. Was this unit used on any other years, or cars? I'm hoping to find one at a junk yard. Is this a part that I could install myself? If there are any good mechanics in the Dallas area, I would appreciate a recommendation.
Thanks
 

·
Registered
Joined
·
7 Posts
The AC has gone out on my Pathfinder. The shop I took it to says I need a new AC Control Head. This is a very expensive part from Nissan. Was this unit used on any other years, or cars? I'm hoping to find one at a junk yard. Is this a part that I could install myself? If there are any good mechanics in the Dallas area, I would appreciate a recommendation.
Thanks
Can you explain what the control head is? if you in controls in the cabin, I found many on eBay priced $45 to $75. Check this out.
2001-2002 Nissan Pathfinder Temperature Heat Control Automatic w/o Navigation | eBay
I might need one, as mine is blowing hot air.
 

·
Registered
Joined
·
1,004 Posts
Can you explain what the control head is? if you in controls in the cabin, I found many on eBay priced $45 to $75. Check this out.
2001-2002 Nissan Pathfinder Temperature Heat Control Automatic w/o Navigation | eBay
I might need one, as mine is blowing hot air.
That may be the control head and may not. Most Nissans have an "AC Auto Amp" buried under the dash that actually controls the HVAC functions, with the dash display being just a display and knobs. There are a few older models where they were integrated, but I don't know specifically for an '01 Pathy.
 

·
Registered
Joined
·
7 Posts
That may be the control head and may not. Most Nissans have an "AC Auto Amp" buried under the dash that actually controls the HVAC functions, with the dash display being just a display and knobs. There are a few older models where they were integrated, but I don't know specifically for an '01 Pathy.
Thanks. Mine is blowing hot air no matter what temp I set in "Auto" . I created a new thread for my issue. Can you pl comment on that?
 
1 - 4 of 4 Posts
Top