Nissan Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
29 Posts
Hi,

I had the same problem with my 01. I used to get a real rough idle / hard start and it would set a catalyst code. Now, I like my PF but not to the tune of new cats. So I just left it alone and reset before inspections.

About two months ago I started getting a misfire code, but it would not pinpoint the cylinder. Two weeks later the bad coil finally failed - these were the replacement coils, about 5 years old, but the new part #s.

Hope that helps,

-Rich
 

·
Registered
Joined
·
29 Posts
Hi Justin,

My local dealer swore up and down that there was no update available for my ECU, however after they performed the gas fill recall, I have gotten a code - except for the bad coil. If you can find a good dealer, they can put on the Nissan Consult system and pinpoint the exact problem - but don't be surprised if they recommend new cats. I just waited on mine - it only ran crappy for a few seconds before clearing itself up. I lived with that on and off for about 6 months before the coil was bad enough to throw a code.

Hope that helps...

-Rich
 

·
Registered
Joined
·
29 Posts
I'm no expert - I had also read that all of the coils should be replaced at the same time. My friend, who is a mechanic, recommends this - but that is only because they kept getting complaints about the other coils failing after a single repair. I believe that dealers also recommend this course for the same reason. Another posting (maybe even on another board) mentioned that the new version of the coils have a small black dot - which is just a sticker, on the new versions of the coils. I noticed them on mine when I replaced the bad one.

My pf has over 100k miles now, so I only replace what is broken...
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top