Nissan Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Yesterday while driving home from work in heavy snow my service engine light came on and the i noticed my engine temprature was on the maximum and after i shut it off and started again it kept going up every 3 miles or so ,i took it to a local franchise and the said there was nothing wrong and the only trouble code was engine overheatin ,i drove it for 30 minutees today and it did not overheat could this be like a one time incident maybe my thermostat getting stuck or something,head gasket seems okay i dont see any white smoke ,coolant level was okay does somebody have any opinions and i not very knowledgable about cars either
Thanks in advance
 

·
Will work for beer
Joined
·
2,696 Posts
sonds to me like it was a one time thing...

is your coolant fairly new?
I've seen this happen a few times a year when there's old coolant or an improper mix in the radiator.. the coolant in the radiator will freeze and prevent the water pump from pushing the coolant though the system- thus overheating the engine.

When you got it home or whatever, I'm assuming the coolant thawed out and now the system is able to pump the water through and keep it cool.

I would suggest taking a look at the coolant and flushing the system out if the coolant is more than a couple of years old. DO NOT use the Dex-Cool crap. (there's currently a class action lawsuit out against that stuff because of engine corrosion).. just put the regular green stuff back in and mix it 1/2 and 1/2. works great, never had problems with it. change it at least every two years, if not every year.. for $8 a year, it's cheap peace-of-mind to replace it and make sure it's always in good shape.
 
1 - 2 of 2 Posts
Top