Nissan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello,

I just had a local mechanic change my ignition coils in my 2000 Maxima. As I drove away from his shop my TCS OFF and SLIP dash lights illuminated. I called him back and he said he probably just hit the traction control button and to turn it back on. I tried it...didn't work.

I next went to Advance Auto Parts and tested the computer and it came up with the codes:

P1320 - Manufacturer control ignition system or misfire – (ignition signal – primary)

P0141 - 02 sensor heater circuit malfunction (bank 1, sensor 2) - Rear H02S Heater, Bank 1

P0161 - 02 sensor heater circuit malfunction (bank 2, sensor 2) - Rear H02S Heater, LH Bank Or Bank 2

P1165 - Manufacturer control fuel air metering - Swirl Control Valve Control Vacuum Check Switch

P1131 - Manufacturer control fuel air metering - Swirl Control Solenoid Valve

P1320 - Manufacturer control ignition system or misfire - Ignition Signal, Primary

P1165 - Manufacturer control fuel air metering - Swirl Control Valve Control Vacuum Check Switch

P1131 - Manufacturer control fuel air metering - Swirl Control Solenoid Valve

What?! I really have no idea why all of these codes are on, and was wondering if anyone could tell me what the deal is? Did the guy totally F up my car?

Thanks!!!
 

·
Registered
Joined
·
3 Posts
Disconnect your battery negative..reset the codes

Did you have any misfire codes prior to him working on it?.If so you have more problems than just the coils according to those codes.If you had the ses light on for awhile and kept driving it you may have damaged other sensors.I would reset the light and see what happens.As soon as it comes back on get the system scanned for codes and repair just those...I think you just have a few because a couple of them are repeats..good luck!.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3 (Edited)
Faulty Ignition Coils?

So I got all of the codes resolved except for the P1320. My mechanic changed my plugs and reset the computer. When the codes are reset, the traction system works perfect; but once you shut down the car and restart it the TRAC OFF and SLIP illuminate and the traction system disables. I am now wondering if the ignition coils I ordered from some online parts store are faulty? Any ideas anyone?

I read on a different post that faulty ignition coils can cause the TRAC OFF and SLIP lights to illuminate - like I said on previous post, those lights were not illuminated until after I had my coils replaced (no lights were illuminated prior to ignition coil replacement). Also, those two lights are the only lights that are illuminated now (No SES or Check Engine).

The car has no power problems and runs like an absolute top. I am just baffled (so is my mechanic) on why the P1320 codes are still showing and why the TRAC OFF and SLIP lights are still on.

Any help would be appreciated! Email at [email protected] or post! Thanks! :)
 

·
Nissan Technician
Joined
·
826 Posts
This IS a common problem with cheap, bargain ignition coils! Put some oem Nissan coils back in and watch the problem disappear. We had an aftermarket shop bring us a Maxima for this exact problem and we put oem coils in.
Problem solved...good luck!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
It's Fixed!

Just thought I would let everyone know there is a happy ending with my Maxima! I had my mechanic put in new OEM coils and the P1320 code went off and the TRAC OFF and SLIP lights turned off! My traction system works excellent now! Now I can tackle Minnesota winters easily!

Thanks for all your help JoeMechanic and metro273! You guys are lifesavers! I hope this thread helps other Maxima owners and remember to buy OEM coils if you ever have to get them replaced!
 
1 - 5 of 5 Posts
Top