Nissan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a technical question. I have a 1998 Nissan Frontier and the temperature gauge has started going up and down . Sometimes it reads right , but other times it will not even move. I had the sensor replaced , so I know that works fine. Any suggestions???
Help!!
 

·
Registered
Joined
·
1,290 Posts
bigC said:
I had the sensor replaced , so I know that works fine.
Help!!
I don't know replacing the sensor necessarily rules out the possibility of a bad one; you could have gotten another "brand new" bad one.

But, if it is accurate and there is no wiring problem or gauge problem, then I'd check my fan clutch and make sure it's working.

Does the temp go up and down when the driving conditions are constant (e.g., driving down the highway)?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
jerryp58 said:
I don't know replacing the sensor necessarily rules out the possibility of a bad one; you could have gotten another "brand new" bad one.

But, if it is accurate and there is no wiring problem or gauge problem, then I'd check my fan clutch and make sure it's working.

Does the temp go up and down when the driving conditions are constant (e.g., driving down the highway)?
It never goes above the middle like it is hot , but it will jump around whicle driving and sometimes it works fine. Other times it will say cool and never move. The gas gauge is on the same gauage and it never works , so maybe it it the gauge but I can't find one anywhere.
 

·
Registered
Joined
·
1,290 Posts
bigC said:
It never goes above the middle like it is hot , but it will jump around whicle driving and sometimes it works fine. Other times it will say cool and never move. The gas gauge is on the same gauage and it never works , so maybe it it the gauge but I can't find one anywhere.
If it's jumping, it could be the gauge, but I would check the wiring for a short or bad ground too.
 
1 - 4 of 4 Posts
Top