Nissan Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Okay so heres my dilemma, i've been reading around to see if anyone here has a similar problem as i do. But here goes anyways. So it started a week ago where my car would idle rough to the point where the RPM would be VERY erratic jumping from 500 to 2500 and then to 1000 never staying in one spot. The car will either die as if fuel was just shut off from the car sputtering and just not running anymore. Been happening to me for awhile. I have replaced the fuel filter, ignition coil, and ignition coil module. Checked for my fuel pressure it was where it should be 43 psi when ignition is "ON" and 34psi when car is started up. But the problem only occurs when the car is warm-hot. Cold starts it is running fine. Any solutions or ideas on how to fix the problem? any help woul dbe great!. I am either thinking of replacing the o2 sensor, distributor, or fuel pump and hoping one of those replacements will fix the problem.
 

·
Registered
Joined
·
6 Posts
Since it's only when warm, it could probably be in the egr circuit. Try plugging the hoses in and out of the egr valve and solenoid. It'd have to be a pretty big hole (relatively speaking) to make that violent of a rev swing.
 

·
Registered
Joined
·
6 Posts
i bet its your injectors, when the coils in them go bad it will not allow the circut to be completed in the injector not giving it the juice to open and close to allow fuel to pass through it and spay into your intake. the easiest way to tell if this is the problem is to to get the engine to its normal running temp or until it starts acting up, then shut it off, pull the electrical connectors off each of your injectors and ohm test them with an ohm meter touching the two leads fom the ohm meter to the metal prongs on the injector itself. they should read 11-12 when hot if they are very low or high or bounce all over the coils are bad and you should replace all of them. remember, if you cant afford to fix it once can you afford to fix it twice? I had a problem like you with my car a '97 and thats what I did. I bought a set from Motor Man fuel Injection for 35.00ea, thats the best price I found. I talked to the owner Howard he was extremely smart when it comes to fuel injectors. I reccomend you get a hold of them if you have a injector problem.
hope this helps you out
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
alright thanks i'll give all of those a try. Just got done replacing my water pump and radiator with all the hoses last weekend due to school its been kinda hard finding the time to work on the beast lol. would using premium gas mess up my car as well? or should i be always using regular? just a simple question lol!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
well tested my injectors with the ohm reader after driving it around for 30 minutes and all injectors read like around 11.0- 11.3 so guess the injectors so no go there.
 

·
Registered
Joined
·
4 Posts
hi i have a 94 altima gxe and have the same problem i baught the car for 300 dollars it only has 1310011 miles on it and it been sitting the guy told me for like 3 years i got it to my house and turned it on it took a while to turn on but it did the car idled fint then it kept overheating i did the headgasket changed the water pump and thermostat then it was fine turned it on and soon as it warmed up and ill give it gas it will start poppin in the intake and if i would leave it on and dnt touch it it would cut off by itself but when i start it and give it gas when its cold its fine i change oil gas filter aired out the gas lines changed spark plug wires cleaned the fuel pump filter i dnt know what else to do plz help:mad::mad::mad::mad:

p.s. if cant fix car im goin to sell it for 800 if anybody interested

o yea also i changed the injectors and now the oil light is on somtimes it flashes
 
1 - 9 of 9 Posts
Top