Nissan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
The display on the radio is not illuminated when the radio is on. Possibly the bulb? Oddly enough, sporadically it does work, but after turning the radio off and then immediately back on the light is off again. Before I make an attempt to pull the radio, could it possibly be a grounding issue elsewhere in the car? Might the bulb be easily accessible once the radio is pulled if I go that route? Any suggestions on resolving this issue will be appreciated. Thx.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
With all these views there isn't a one of you that can't offer any help? For heavens sake, I can't navigate the stations without the display lit. Is pulling the radio out my only remedy? Is the bulb easily accessible?
 

·
NF Mod/Nissan Master Tech
Joined
·
9,471 Posts
There were two different head units, if I recall correctly, Hitachi and Clarion. I don't recall the bulbs being readily serviceable, meaning one would have to disassemble the unit to replace them. But, if the bulbs worked sometimes and not others, that would seem to indicate that it's likely not a bulb issue, but a poor electrical contact or intermittent circuit "open." If the problem turns out to be inside the unit, I would try searching YouTube for a video on how to fix the problem. If one can't be found, one might be better off sending the head unit out to be repaired. They would touch up all of the solder joints while they are in there in most cases, which could be the issue with your unit.
 
1 - 5 of 5 Posts
Top