Nissan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
:mad:Hi all i have a Datsun 510 with a 1982 200sx engine swap. The car was running great until two days ago. The problem i have been having is when i accelerate anywhere from 2000-3000rpm the car starts sputtering the tach would also start jumping. It probably died on me 3 times before i decided to give it a tune up.I changed the fuel filter, plugs, wires, and air filter i also made sure i was getting spark from the coil and everyting seemed to be fine and after the tune up i drove the car and it continued to sputter.
Finally Just yesterday i was on the highway cruising and my tach meter which is an aftermarket tach that is connected to the + side of the coil all of the sudden dropped to "0" and the car sputtered and died on me. I got it towed home and when i began taking a look at it i found out i now have no spark coming from the coil to the dist. I checked the + side of coil and everything seems to have current its just not coming out of the coil. What can it be? Could it be the dist.? Or the ignition module? Everything lights up and the engine turnes over but the spark isnt there!! any help would be shurley appreciated!!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
so i bought a new dist. and it still didnt work so then i bought a new coil and after i put it in i turned the engine and it started! BUt then it turned off and now it wont start again. THere is no spark coming from the coil yet again. Im frustrated!!
 
1 - 2 of 2 Posts
Top