Nissan Forum banner

1 - 2 of 2 Posts

·
Towards Antisocial
Joined
·
592 Posts
Discussion Starter #1
'04 SpecV, 64K miles. Nismo I/H/E. No problems before.

Cruising along at 45-50mph last Sunday. Feel this split-second fuel cut. Happens twice. Drive the car home, park it. No CEL. Start it up later that evening, test drive, happens again once or twice. Park it. No CEL still.

Monday morning, car is towed to Nissan of Brandon. Late in the day, they tell me they believe its the MAF and want $825 to fix it. I give them the green light. MAF is out of stock, will be in tomorrow.

Tuesday, they tell me its not the MAF, and its not the o2 sensor, and they have 3 of their mechanics scratching their heads at the issue. They think its an ECU, it has to be. The ECU is out of stock, it will be in tomorrow.

The new MAF "doesnt like the nismo CAI and runs better in the factory plastic pipe". Whats the difference to the maf sitting in a Aluminum or plastic pipe that is hanging off the throttle body, with no more intake connected beyond it? They couldn't answer that. Car is getting fuel pressure but is running lean. Plugs are fouled (white).

Wednesday, they put me in a rental car no charge. A Toyota Yaris. I lost my girl, my place, my dog last month a week before I turned 30, and this month my SE-R... And im in a Yaris.

Yesterday I go up there, no updates. ECU was never installed, but it had arrived.

Its 12:30pm Friday, no call from dealership, still. I brought it to the dealership because I didn't want hassle. I love cars but I hate working on them anymore. I've forgot more about Nissans than 90% of their customers, I would think they wouldn't be trying to pull the wool over my eyes when their are easier targets.

Thanks for reading, i'll update as things progress. Thoughts, comments?
 

·
Registered
Joined
·
790 Posts
You're initial problems sound much more like a Crank Position Sensor going bad. There IS a recall on the sensor. During that split second fuel cut does your tach die out, then resume operation? Also, were you experiencing increasing long starts?

That whole thing about the MAF not liking the Nismo CAI is garbage. They probably just slapped a new MAF on there and it's possibly idling funny. An Idle Air Volume Relearn should work just fine. Again, nothing is wrong with having a Nismo CAI.
 
1 - 2 of 2 Posts
Top