Nissan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
I have an 01 pathfinder that seems gutless getting up to 60mph+ and up hill or just getting up to speed in a hurry. I tried all the tune ups. spark plugs, filters, checked exhaust for blockage with intake vacuum test. no ses light on. took it to the dealer they said MAF sensor. i changed it with an aftermarket one. there was no difference in the way it performed. truck runs smooth just in and out of having any balls. guessing its electronic. gas mileage very bad too. read something about others with this similar problem. any guesses on fixing my pathy?
 

·
Registered
Joined
·
6 Posts
Check ignition coil packs

hey I have a 2001 pathfinder that had power issues and then SES light came on and took it in and found out i had bad ignition coil packs-very expensive i took it to a local mechanic and he charged me $700 with parts and had to replace spark plugs as well
 

·
Registered
Joined
·
6 Posts
gas mileage for me sucked i was getting like 14 miles to the gallon when normally i was averaging 18- after this major service gas mileage back to normal so i assume the ignition coils were the problem
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
the problem i am having has existed for well over a year maybe two years. about a year ago i did have the plugs changed and my mech. did find 1 bad coil pack. the job didnt change the performance at all.
 

·
Registered
Joined
·
6 Posts
I was having power issues and gas mileage issues as well.. I had a couple of bad coil packs and the mechanic and dealer both said to change them all because once one goes out you will notice all of them go out one at a time.. I think its still a little sluggish at times but definetely more responsive than before. Have you changed the Mass air flow sensor?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
I did last week change the mass air flow sensor. there was no change in the way it ran. the problem seems to be intermittent. good power up to quarter throttle. truck starts runs smooth. how did yours run with bad bad coil packs?
 

·
Registered
Joined
·
6 Posts
With the bad coil packs it ran very sluggish.....when it misfires it felt like the truck wanted to cut off. It didnt go past 55-60 mph so i knew something was wrong ...so i took it to the dealer and he said to change all the coil packs and put new plugs since it hasnt went for a tune up yet. So i took it to a friends mechanic and he changed all 6 coil packs and plugs and then it started driving better and the gas mileage definetelty was better so i knew the coil packs along with the plugs made some change. It drives a little sluggish when i first turn it on ....but when it warms up it drives good again.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
mine never breaks down it will rev to red line. slow getting there though. even in neutral or park. a friend looked at it said passenger side catt. converter rattles. thinks its broke inside creating an intermitent problem when its bounced around. Mech. did a back pressure test. said it measured fine. i did an intake vacuum check. it measured fine. friend said to check em visually. i will take them off myself. i'll check in soon.
 
1 - 8 of 8 Posts
Top