Sr20det still runs after turning off. - Nissan Forum
SR20DE/DET Engines 1991-2002 Silvia

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Jun 19th, 2016, 07:13 PM Thread Starter
Nissan Enthusiast
 
Joined: Nov 2011
Posts: 41
Sr20det still runs after turning off.

I got my Sentra with the Avenir sr20det swap running. Any idea what could be causing it to run after I turn it off? When I turn the car off the engine still runs for about four seconds before it shuts off. What's causing this, and what do I need to do to fix it?

34Diesel34 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Jun 19th, 2016, 09:05 PM
Sup Mod keeping the peace
 
rogoman's Avatar
 
Joined: Dec 2004
Location: NJ (Philadelphia area)
Posts: 5,996
That condition is called pre-ignition and is generally caused by the following:
* Running the engine with an extremely lean mixture. This could be caused by a major vacuum leak in the intake system.
* The coolant being at around the boiling point for some period of time greatly overheating the combustion chambers.
* Carbon deposits on the pistons.
* Over-advanced ignition timing.
* Using a lower octane fuel then required.

KA-T for life, yo!
rogoman is online now  
post #3 of 4 Old Jun 19th, 2016, 09:13 PM Thread Starter
Nissan Enthusiast
 
Joined: Nov 2011
Posts: 41
I'm running premium unleaded 93 octane in it. Would retarding the timing on the distributor help?
34Diesel34 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old Jul 7th, 2016, 08:20 PM Thread Starter
Nissan Enthusiast
 
Joined: Nov 2011
Posts: 41
Problem fixed. The fuel injectors were connected to the battery instead of the ignition switch. The car turns off like it's supposed to now.
34Diesel34 is offline  
Reply

  Nissan Forum > 240SX/Silvia/S12 200SX > SR20DE/DET Engines

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
SR20DET runs horrible NW Perf SR20DE/DET Engines 5 Jul 23rd, 2008 12:58 AM
car runs out of gas when turning left tj4207 B14 95-99 chassis 4 Aug 16th, 2005 11:50 AM
I am between a rock and a hard place , SR20DET B14 or SR20DET B13. Please help! PatScottAKA99XE Forced Induction & Nitrous Oxide 16 Aug 6th, 2004 12:56 PM
runs good one day runs shitty the next day!! BIGBALLER GA16DE 1.6L Engine 2 Aug 21st, 2003 12:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome