Nissan Forum - Reply to Topic
B14 95-99 chassis 1995-1999 Sentra and 1995-1998 200SX

Thread: New guy needs help W/PS... Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
Jul 6th, 2002 01:53 PM
landlord
$tealer$hip$

yeah,

i just bought my car lucky it had a warrenty because the timing chain was on its last limb (I knew this when i bought it commen problem.) any way when i got it back it felt like the clutch wasnt disengaging all the way. well i looked at it the other day and those wonderful mechanics thought they would be nice and adjust my clutch cable for me!!! i dont know why maybe they wanted to get some money back they lost on fixing the car. any way i dont go to a $tealer for any thing the only reason i took it there becaus replacing the chain is a pain and expensive.
Jul 5th, 2002 06:54 PM
tonsters200 ************************************************** **
UPDATE: Upon further investigation I found that the return hose to the power steering unit was not tight. I almost pulled the hose off with a just a gentle pull. I'm glad I don't have to replace the pump just yet. I do however have concerns with the dealer as they are the only ones who work on my car and the hose was obviously loosened. I don't have proof of course, but I will not be going to that specific dealer anymore. The hose in question was like 3-4 inches from the oil filer and can only be loosened from under the car. Very suspect...
Jul 4th, 2002 08:40 AM
tonsters200
New guy and PS problem ***UPDATE Problem found***

Just found this site (Looks like yet another web vice for me!!!) while searching the net for some power streering pump replacement info. I have a 96 1.6 200SX. What I was wondering was has anyone on here replaced the pump themselfs??? If so how hard was it??? Was it easier to get to from the bottom?? Thanks guys.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome