Question about HB cluster - Nissan Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old May 23rd, 2019, 07:26 AM Thread Starter
Nissan Enthusiast
 
Joined: May 2009
Posts: 181
Question about HB cluster

I have Ka24e 2.4l

My cluster is a replacement from boneyard. I have realized it came from a V6. When I take off in 1st gear, at about 3.5k your pass time to shift.

So anyway I seen a post someone mentioned a switch on tach from 4cy to v6, Is this true?

One other thing, if there isn’t a switch, with the tach not being right and off adjustment. What should my idle be at to be right?

Azazel is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old May 23rd, 2019, 12:05 PM Thread Starter
Nissan Enthusiast
 
Joined: May 2009
Posts: 181
So I took clustervout and on back of tach is a screw with arrow shape. Board labels VR1, D3, ZD21
So if I turn it all the way over to left in picture, I’m hoping is for 2.4

[/URL]
Azazel is offline  
post #3 of 11 Old May 23rd, 2019, 12:10 PM Thread Starter
Nissan Enthusiast
 
Joined: May 2009
Posts: 181
Well maybe needs be all the way to right, ZD21 has arrow pointing to d3 point
Azazel is offline  
Sponsored Links
Advertisement
 
post #4 of 11 Old May 23rd, 2019, 04:33 PM Thread Starter
Nissan Enthusiast
 
Joined: May 2009
Posts: 181
So moving that knob over to far right worked. Tach now hits redline if I choose to do so. But now I can’t get the idle right. It’s staying at 1300. I checked the timing with TPS disconnected, timing was out but now have it at 10 degrees, I have new TPS set to .45v. When adjusting the idle screw to almost completely shutting it off (turning to right) the idle never drops below 1200. So is the idle control valve bad? The idle don’t sound like it’s as high as it say on tachometer.

Or is it the FIC. Here is a pic of the adjusting screw. Does it look right?




I would like to see a picture of someone’s throttle body fic alignment mark when hot and the adjusting screw thread count. That is set right. If anyone has a picture would be grateful for it.
Azazel is offline  
post #5 of 11 Old May 24th, 2019, 05:10 AM
Software Developer
 
jp2code's Avatar
 
Joined: Jun 2011
Location: Longview, TX [USA]
Posts: 550
Garage
Idle should be around 700 RPM when the engine is warm.

I've seen others post that the Potentiometer needs to be adjusted for the engine size, but I don't remember what it was.

What exactly are you wanting a picture of? And what engine and what years are you interested in?

~Joe (not a mechanic!)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jp2code is offline  
post #6 of 11 Old May 24th, 2019, 05:32 AM Thread Starter
Nissan Enthusiast
 
Joined: May 2009
Posts: 181
It’s 1995 2.4l Hardbody 4x4

I would like to see a picture from someone’s truck of the throttle bottle FIC warmed up. What I have circled in the blue. The roller and alignment mark, The screw A locking nut placement. How many threads are above the locking nut.

Azazel is offline  
post #7 of 11 Old May 24th, 2019, 03:55 PM Thread Starter
Nissan Enthusiast
 
Joined: May 2009
Posts: 181
Alright, so I got the idle down by turning the screw to the left that is circled in red in pic below.
How do I figure out the right setting for the screw circled in red?



On the IAC say I turn that screw completely to the right till it stops, how many full turns left is default?
Azazel is offline  
post #8 of 11 Old May 27th, 2019, 02:31 PM Thread Starter
Nissan Enthusiast
 
Joined: May 2009
Posts: 181
So here is a picture from manual of FIC



Here is a pic of My FIC in a Cold position



Then a Pic of my FIC at normal operation temperature position

Azazel is offline  
post #9 of 11 Old May 27th, 2019, 08:38 PM Thread Starter
Nissan Enthusiast
 
Joined: May 2009
Posts: 181
So I adjusted FIC again. I unplugged TPS, and adjusted screw A down till the top of cam pointed to center roller. Once I did this I adjusted the screw that I circled above with the yellow paint which is throttle valve plate. Depending how far this is adjusted down seems to advance timing. Distributor had to be adjusted back to 10 degrees.

So I turned it 2 full turns once the throttle plate moved. Then I used a nickel to gap the roller on FIC , started truck 1500 rpm, tired adjust IAC but seemed to be turned in to far to get idle down, turned it off and backed the screw out one full turn, adjust roller again, checked timing, Start truck rpm 500, adjusted IAC turned to left about 2 full turns, idles at about 800 now. Adjusted TPS to .45

Test drove around the block, still seem hesitant/sluggish then like get boost, shifts are smooth but don’t feel no power boost

I unhooked IAC and didn’t notice a speed decrease or increase, so when I unplug the IAC should I notice a instance decrease in idle?

The truck runs smooth but idle at normal temp will shift slightly, slight increase then decrease, This happen with IAc plug connected or disconnected. Is IAC bad?

I’m going to get a fuel pressure gage tomorrow and do some more testing.

Going check throttle cable tomorrow also, I know mine is tight but not sure if it’s tight where it’s starting to pull the drum over, which may explain the gap in take off and between shifting gears.

Last edited by Azazel; May 27th, 2019 at 08:42 PM.
Azazel is offline  
post #10 of 11 Old May 31st, 2019, 09:12 AM Thread Starter
Nissan Enthusiast
 
Joined: May 2009
Posts: 181
Vacuum is showing good on gage, testing fuel pressure I have 40 psi never dropped below this unless I put vacuum on pressure regulator, which it would drop then.


The Truck runs awesome when I drive off in morning while cold. Power is there and feels right.

But once it’s warm it’s like you have no power band when shifting gears,

When Ac is on the slightest incline seem to bog down the speed and downshifting barely gives boost to gain speed back.

So I don’t know if it could run like it does when cold I would be extremely pleased with it.

But unfortunately once it gets normal temp power is no longer there and I don’t know what else to try. I’ve searched web and seen some post with this problem but never have found one with the solution.
Azazel is offline  
post #11 of 11 Old Jun 2nd, 2019, 01:17 PM Thread Starter
Nissan Enthusiast
 
Joined: May 2009
Posts: 181
All adjustments are made with TPS disconnected.

So I have searched the web for pictures of Ka24e Throttle body. Of the pictures I have found it looks like FIC (Set Screw A ) should have 7 threads showing from lock nut to top of screw. (Set Screw B) looks to have 12 to 13 threads showing.
Now the screw that should have never been touched. The Throttle Stop Screw. Have not been so lucky with a picture of this Screw, I found one and it’s blurry. So once I had Set Screw A and B set I adjusted the throttle stop Screw till I had idle around 600rpm, ( make sure you having a timing light hooked up) adjusting this Screw retard/ advances time depending how far you Screw it in or out. Adjust timing with distributor. Also Set Screw B needs adjusting after turning Throttle Stop Screw.

Once I got idle at 600rpm I used the Screw on IACV to raise it to 750-800. Rev it at 2k for couple mins, turned truck off ,adjusted TPS hooked tps up and that’s it.

My truck now has what I would say normal power. Ac on in 3rd gear, I can feel power when I bump the pedal, accelerating.

Amazing how out of wack I had this all because I had the tachometer set for V6

If I knew the exact or average IACV number of turns from closed position on the adjusting Screw, I could fine tune the Throttle Stop Screw better.

Set Screw A: 7 threads
Set Screw B: 12-13 threads
IACV : ???

But knowing these 3 defaults you would then just adjust Throttle Stop Screw to the right idle and adjust Set Screw B into spec with any turns of the Throttle Stop Screw.

So if anyone has a throttle body that is factory set, that would like to confirm these thread counts on these screws and IACV count on idle Screw be much appreciated.

Hope this can help someone out down the road.
Azazel is offline  
Reply

  Nissan Forum > Truck & SUV > HB Truck

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
B13 Electronic Cluster Swap to Nx1600 Digital Cluster Question ! Moparfans B13 91-94 chassis 1 Mar 9th, 2010 07:51 PM
r32 guage cluster 260 cluster infinty_S13 S13 240SX 1989-1994 0 Dec 8th, 2005 11:37 PM
Cluster after cluster zexxyprelude S13 240SX 1989-1994 1 Dec 10th, 2004 08:31 AM
Looking for a gauge cluster with a tach to put into my 94 non tach cluster 94Sentra Canada & International 0 Nov 10th, 2003 02:09 PM
Good autoshop to swap my non-tach cluster with a tach cluster? 94Sentra B13 91-94 chassis 2 Nov 10th, 2003 11:35 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome