97 maxima pls help - Nissan Forum
General Maxima Discussion For general Maxima discussion

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Feb 27th, 2014, 04:23 PM Thread Starter
NissanForums Newbie
 
Joined: Feb 2014
Posts: 1
97 maxima pls help

i have a 97 maxima, the temp gauge sometimes stays cold, sometimes reads normal, and sometimes jumps straight to hot, then it may or may not go back down again. when it gets hot, coolant will spray out from where the hose connects to the radiator. sometimes, but not always, the gauge reads cold, and the radiator will be cold, but the engine will be smoking, other times the engine is cold but the radiator is hot. could this be a clogged radiator, a bad thermostat, or both?

screamingdreamer is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Jun 11th, 2019, 07:31 PM
NissanForums Newbie
 
Joined: Jun 2019
Location: Henderson NV
Posts: 4
radiator rework and new thermostat! Had to do both on my 97 maxima
bummedoutjohn is offline  
Reply

  Nissan Forum > Maxima > General Maxima Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
97 maxima tachometer problem PLS HELP!!! unzip2000 A32 1995-1999 Chassis 5 Dec 26th, 2009 03:21 AM
92 maxima rough idle and loss of power pls HELP!!! badboy112 J30 1989-1994 Chassis 1 Jan 10th, 2009 11:07 PM
pls give me some INFO pls!!!! ohmaild E/CA-Series & GA16i Engines 7 Oct 6th, 2007 12:01 AM
HELP!! Any maxima gurus pls help! Jku520 New Member Forum 2 Jul 10th, 2004 06:41 PM
Pls Help RIZZ0 GA16DE 1.6L Engine 5 Oct 2nd, 2002 10:05 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome