Speedometer stopped working - Nissan Forum
General 240SX/Silvia/S12 200SX For general 240SX/Silvia/S12 200SX discussion

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Dec 12th, 2017, 06:13 PM Thread Starter
NissanForums Newbie
 
Joined: Dec 2017
Posts: 2
Speedometer stopped working

i have a 86 200SX perfect condition and only 86k miles and 2 weeks ago the speedometer stopped working along with the mileage counter. everything on the dash works perfectly. I'm having trouble with seeing if the car has a speed sensor, or just a cable or does it send a signal to emc control box? I want to fix this asap cause like i said the car is in perfect condition all original a/c works a perfect car.

scottishere99 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Dec 12th, 2017, 10:34 PM
Sup Mod keeping the peace
 
rogoman's Avatar
 
Joined: Dec 2004
Location: NJ (Philadelphia area)
Posts: 5,982
The car uses a speedometer cable between the tranny and the speedo head in the dash. The problem could be the speedo gear in the tranny or the cable itself or the speedo head in the dash.

KA-T for life, yo!
rogoman is online now  
post #3 of 5 Old Dec 13th, 2017, 04:48 AM
NF Mod/Nissan Master Tech
 
smj999smj's Avatar
 
Joined: Jan 2006
Location: Prospect, VA
Posts: 9,195
Speedo head failure was pretty rare on those models. Bad speedo cables and stripped teeth on the plastic pinion gear were a lot more common "back in the day".
smj999smj is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old Dec 16th, 2017, 09:19 PM Thread Starter
NissanForums Newbie
 
Joined: Dec 2017
Posts: 2
Where is the location of the cable on the transmission and do you know where I can see a picture of it so I know what I'm looking for
scottishere99 is offline  
post #5 of 5 Old Dec 17th, 2017, 05:49 PM
NF Mod/Nissan Master Tech
 
smj999smj's Avatar
 
Joined: Jan 2006
Location: Prospect, VA
Posts: 9,195
I don't have a picture of the cable, but I can link you to a picture of transmission which shows the location of the speedometer pinion, to which the cable connects:

Manual transmission, CA20 engine:

https://www.nissanpartsdeal.com/part...iagram=320_A01

Automatic transmission, CA20 engine:

https://www.nissanpartsdeal.com/part...iagram=310_A01

It should be on the passenger side of the transmission in either case.
smj999smj is offline  
Reply

  Nissan Forum > 240SX/Silvia/S12 200SX > General 240SX/Silvia/S12 200SX

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer Stopped Working mrexcel A33 2000-2003 Chassis 0 Jul 12th, 2013 11:28 PM
Speedometer and Odometer Stopped 95_200SX GA16DE 1.6L Engine 2 Jan 15th, 2010 02:33 PM
Speedometer stopped working! BeachBuggy HB Truck 13 Apr 27th, 2009 06:24 PM
Odometer and Speedometer stopped working on my 1995 Nissan HB pickup lac77 HB Truck 5 Mar 12th, 2008 08:25 PM
my a/c stopped working mhconversion Truck & SUV 7 Jun 14th, 2007 10:07 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome