Trailer lights not working at all - Nissan Forum
D40 2004-present Discussions on the Second Generation Frontier.

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Feb 16th, 2018, 09:29 AM Thread Starter
NissanForums Newbie
 
Joined: Feb 2018
Posts: 2
Trailer lights not working at all

Hey, I drive a 2009 Nissan Frontier and have a 4 pin trailer lights connector attached to the back. In the past my trailer lights have worked (without the three additional relays behind the passenger kick panel) but recently have inexplicably stopped working. The trailer lights function fine when connected to another vehicle. I purchased the three relay kit and installed it (link below for the 7 pin version, I have the four pin), and the lights still do not work. My fuse is not blown. The 4 pin pig tail attached to the harness under the rear of the car has continuity and is not corroded. Via volt meter I have come to the conclusion there is no power reaching the rear harness under the car on any pin.

In short, I believe the source of the problem is somewhere in between my battery and harness attached to the frame under the rear of the vehicle.. Lucky me.

Any suggestions for where to start looking for the problem? Thanks

https://www.etrailer.com/Custom-Fit-...ha/118266.html


Last edited by jtodd630; Feb 16th, 2018 at 09:40 AM.
jtodd630 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Feb 16th, 2018, 07:23 PM
Nissan Fanatic
 
Joined: Jun 2014
Posts: 343
Did you check the ground wire on the Trailer?

Barney,
2013 SV V6/4L AT 2WD KC Frontier/Current; '93 Hardbody KC,2.4L/IL4,AT,2WD, O.O./20yrs./Sold
BRubble is online now  
post #3 of 5 Old Feb 17th, 2018, 01:23 AM
NF Mod/Nissan Master Tech
 
smj999smj's Avatar
 
Joined: Jan 2006
Location: Prospect, VA
Posts: 9,151
I would start by checking the fuses. The relays are only needed if you are going to install an electronic brake controller w/ the 7-pin trailer connector; it's not needed for the 4-pin connector.
smj999smj is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old Feb 26th, 2018, 09:25 AM Thread Starter
NissanForums Newbie
 
Joined: Feb 2018
Posts: 2
@smj999smj , fuses are all good as well, and yes @BRubble trailer ground is good. Trailer lights functioned fine when connected to another vehicle.
jtodd630 is offline  
post #5 of 5 Old Feb 26th, 2018, 07:31 PM
Nissan Fanatic
 
Joined: Jun 2014
Posts: 343
Quote:
Originally Posted by jtodd630 View Post
@smj999smj , fuses are all good as well, and yes @BRubble trailer ground is good. Trailer lights functioned fine when connected to another vehicle.
Did you check continuity at the connector in the back that the 7 Pin plug's into? Maybe in your case 4 pin, if you didn't switch over to the 7 pin. It's been a while since I did the install,, but on mine it was somewhere close if not on the Left Frame Rail.

Did you check all the fuse's under the hood as well as in the Cab?

If all the Fuse's are ok, then maybe a wire underneath got snagged, bitten, or otherwise broken.

I don't know what all those connector/'s coming off of the Positive Battery Terminal are,, but are your Battery terminal corroded or have been and might have damaged one of those connector's. I haven't looked too close,, but they may be a form of fuse comeing off of the Positive Battery Terminal. I've seen picture's of those corroded Positive Battery Terminal's and the connector's comeing off of it,, and quiet a bit of damage to those circuit's. I use Grease on my Terminal's to prevent corrosion.

Barney,
2013 SV V6/4L AT 2WD KC Frontier/Current; '93 Hardbody KC,2.4L/IL4,AT,2WD, O.O./20yrs./Sold
BRubble is online now  
Reply

  Nissan Forum > Frontier Truck > D40 2004-present

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
dash lights, tail lights possibly brake lights not working after aftermarket stereo carguy013 X-Trail 12 Apr 28th, 2015 10:46 AM
Trailer lights needu X-Trail 0 Jan 23rd, 2013 11:17 AM
2007 Frontier trailer running lights not working MTKNISSAN D40 2004-present 1 Nov 24th, 2009 08:52 AM
Can I bypass the Frontiers BCM and hook up trailer lights to one of my tail lights ? cctmobiledetail General Frontier Discussion 1 Oct 19th, 2008 10:00 AM
Trailer Lights Titanwannabee General Frontier Discussion 5 Mar 27th, 2007 07:30 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome