2014 Altima SL 2.5L Turn Signal Out and Headlight Dim - Nissan Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old Jul 11th, 2019, 01:13 PM Thread Starter
NissanForums Newbie
 
Joined: Jul 2019
Location: Texas currently
Posts: 1
2014 Altima SL 2.5L Turn Signal Out and Headlight Dim

Hey guys,

Just got a 2014 Altima. Front right turn signal is out. Bought two new LED bulbs to replace the old bulbs. Tested both LED bulbs on the left side of the car and they work great, super bright and no hyperflashing. Tried putting the new bulb on the right side of the car, and it wouldn't work. I thought maybe that socket was bad. I took the socket from the right side of the car, moved it over to the left, and that socket worked with one of the bulbs on the left side of the car. So the socket and bulb both work, but no turn signal. Been thinking it was a fuse problem, but I can't find a fuse for any blinkers. I thought maybe the FR Fog and Signal were on the same fuse being so close together but that fuse looks good. Tiny bit of what looks like corrosion on the blades on the outside but the inside metal bit looks to be closed and not blown still. And all the fog lights work fine. Any idea what's wrong here?

On top of that, my right headlight is really dim compared to my left. This was the case both with the halogen bulbs that came with the car, and with some new LED ones I just bought to try and fix the problem. Checked that fuse too and that fuse is fine for the FR headlight. Someone at auto zone said possibly the halogen bulb was positioned wrong, got really hot and melted against part of the housing causing it to not let as much light through? Or melted on some type of reflector or something that's inside the housing. So possibly I'd need a new housing...?

Maybe the headlight is just aimed wrong? Hard to tell.. Saw the sticky for adjusting aim on this vehicle. I'll give that a go when I can and update here with the results

Cheers guys!

Hunter Vivirito is offline  
Sponsored Links
Advertisement
 
Reply

  Nissan Forum > Altima/Stanza > 2007+ Altima

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome