Brake lever/switch problem? - Nissan Forum
Z31 300ZX(T) 1984-1989 Zs - Engine and Chassis Discussion

 
LinkBack Thread Tools Display Modes
#1 Old Mar 13th, 2008, 12:34 PM
NissanForums Newbie
 
Join Date: Mar 2008
Location: Alabama
Posts: 5
Send a message via AIM to Urishen
Brake lever/switch problem?

Hey there all. Got a question regarding the brake light switch. Now I own a 86' 300ZX (Gold) single turbo. now there's two switches on the pedal mount, one (top) is apparently for normal braking, and the second one (bottom) i gather is for cruise control.

when pedal is pressed the lights would come on right? nope.. When my brake isn't touched the lights stay on constantly. Granted when i got this car the (top) switch wasn't even plugged in, and there was a spare switch in the center console for eronious reasons. Well i replaced the switch with said one and thats when i noticed they stay on. even when i pressed the pedal. So i went to my buddy at an auto store, and he looked at it and said "hmm..." What i hadn't noticed is that there are holes on the pedal itself where the switches come through the mount and would and should touch the pedal to cut the lights off when the pedal isn't braking. So i pushed the brake in, and reached under and pressed the (top) switch and the lights cut off, i release it and they turn on.

Now my question is why in the world are there holes there where the switches should be touching metal. Is there a cap of some sort that goes on these holes (on the pedal)? Because I'm about to break out the ol' JB-Weld putty and cap those suckers up. I know pretty well thats my problem. (among other things)

Any help, and or advice on what i mentioned would be greatly appreciated.

Thanks - Rich

Sponsored Links
Advertisement
 
#2 Old Mar 15th, 2008, 03:24 PM
Nissan Enthusiast
 
Join Date: Sep 2007
Posts: 29
i donno dude, i'd ask the previous owner why he put a hole there, mine doesnt have a hole but it has a small round magnet on it to make sure it hits the switch
#3 Old Mar 16th, 2008, 11:47 AM
Z31 know-it-all
 
AZ-ZBum's Avatar
 
Join Date: Nov 2004
Location: Valley of the Sun, Arizona
Posts: 1,020
Send a message via AIM to AZ-ZBum
repairs:brakepedal [Z31.com 300ZX Wiki]

Disclaimer:
One thing you'll find about me is that I can be very helpful to people who take their time to ask complete questions with good grammar and punctuation. I'm also a real ass to people who don't show at least a little effort in their posts.
Z31 Registry
Z32 Registry
#4 Old Mar 16th, 2008, 04:14 PM
NissanForums Newbie
 
Join Date: Mar 2008
Location: Alabama
Posts: 5
Send a message via AIM to Urishen
hey thanks a lot fellas, that last post is exactly what was wrong as i was thinking. So instead of getting those rubber caps or finding who sells them, i ended up using this 2-part epoxy i bought at my favorite auto parts store. Works just as well as the caps do. the best part about this stuff is that if i ever need to take it off, i can always drill or tap it.

Thanks again for the help.

86' 300ZX (w.i.p.)
#5 Old Mar 16th, 2008, 06:29 PM
Z31 know-it-all
 
AZ-ZBum's Avatar
 
Join Date: Nov 2004
Location: Valley of the Sun, Arizona
Posts: 1,020
Send a message via AIM to AZ-ZBum
Quote:
Originally Posted by Urishen View Post
hey thanks a lot fellas, that last post is exactly what was wrong as i was thinking. So instead of getting those rubber caps or finding who sells them, i ended up using this 2-part epoxy i bought at my favorite auto parts store. Works just as well as the caps do. the best part about this stuff is that if i ever need to take it off, i can always drill or tap it.

Thanks again for the help.
I think one of the stupidest things people do is rigging something instead of fixing it right. It only causes more problems down the road. Either for you or for the next owner.

Disclaimer:
One thing you'll find about me is that I can be very helpful to people who take their time to ask complete questions with good grammar and punctuation. I'm also a real ass to people who don't show at least a little effort in their posts.
Z31 Registry
Z32 Registry
Reply

  Nissan Forum > Nissan Z > Z31 300ZX(T)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On