Strange problem - Nissan Forum
 
LinkBack Thread Tools Display Modes
#1 Old Nov 10th, 2012, 06:32 PM
Nissan Enthusiast
 
Join Date: Jun 2008
Posts: 44
Strange problem

Okay I have a Canadian 2006 4wd x-trail on the 2.5 petrol motor.I have had the odd time when the vehicle is warm when I try to start it "sometimes" will not start until I turn off the fan motor from dash. Battery is fine alternator pumps out 80 amps and charges the battery.Last night while going a hill the engine just died no engine light was able to pull over and restart with no problems. Today it sputtered a bit now the check engine light is on ant suggestion? My mileage is 125000kms.

Last edited by derek flint; Nov 10th, 2012 at 06:36 PM.
derek flint is offline  
Sponsored Links
Advertisement
 
#2 Old Nov 10th, 2012, 08:36 PM
Sup Mod keeping the peace
 
rogoman's Avatar
 
Join Date: Dec 2004
Location: NJ (Philadelphia area)
Posts: 4,114
Do an ECU code readout with a scan tool to see what codes are set. Post the codes here on the forum and we'll try to help you.

KA-T for life, yo!
#3 Old Nov 11th, 2012, 12:10 AM
Nissan Enthusiast
 
Join Date: Jun 2008
Posts: 44
I do not have access to a code reader. I am going to bring it to my mechanic on Tuesday just wanted to brace myself. Did call the dealership they "think" it may be a crank position sensor. I believe I have 2 would I have to replace both or just the faulty one?
derek flint is offline  
#4 Old Nov 14th, 2012, 04:11 PM
Nissan Enthusiast
 
Join Date: Jun 2008
Posts: 44
Well it turns out it is a crank position sensor. Problem is it is cracked and if it falls apart big bucks. Btw will the new sensor improve my gas millage?
derek flint is offline  
#5 Old Nov 15th, 2012, 03:53 PM
Sup Mod keeping the peace
 
rogoman's Avatar
 
Join Date: Dec 2004
Location: NJ (Philadelphia area)
Posts: 4,114
Normally a crank position sensor doesn't improve MPG. There is only one crank position sensor on the engine block.

KA-T for life, yo!
Reply

  Nissan Forum > Truck & SUV > X-Trail

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On