Very poor radio reception - Nissan Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Apr 19th, 2010, 11:22 PM Thread Starter
stx
Nissan Enthusiast
 
Joined: Mar 2005
Location: Calgary, AB
Posts: 37
Very poor radio reception

A few months ago the radio reception on my factory head unit dropped out. It was so bad, I just heard static on all FM stations and my iPod FM transmitter wouldn't work properly either. The CD and tape player worked fine so I figured the antenna came loose. I removed the head unit and reseated the antenna connection, but that didn't solve it so I figured my head unit was failing.

Well, two days ago I replaced the factory unit with a Pioneer AVIC-U310BT and had it professionally installed. While the FM reception was a little better on the new system, it was still pretty bad, volume was low and heavy static. The installer suggested I needed to take into Nissan to get antenna connection checked.

Before I do this, has anyone else had this issue? Is there power going to the antenna, and if so, could there be a fuse that needs to be replaced to fix this issue? I just want to avoid taking it into Nissan since they'll probably tell me the reception problems are from my recent deck install.

Thanks.
stx is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Apr 20th, 2010, 06:21 AM
XTRAIL-HOLIC
 
aussietrail's Avatar
 
Joined: Sep 2004
Location: Sydney-Australia
Posts: 2,228
Send a message via MSN to aussietrail
Check THIS thread.

Cheers,
Jalal (Sydney, Australia)

See my X-Trail HERE
See what we have on offer at the
Australian X-Trail Forum or Join us on Facebook
aussietrail is offline  
Reply

  Nissan Forum > Truck & SUV > X-Trail
Gear in this thread - nissan radio by PriceGrabber.com

Quick Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome