code scanner - Nissan Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old Mar 7th, 2005, 03:05 PM Thread Starter
Sorta-Newbie
 
Joined: Mar 2005
Posts: 17
Question code scanner

My 93 Altima put out codes on the ECM but it appears my 95 doesn't. At least when I tried nothing happened.
Does anyone know what a scanner might cost and the manufacturer?
canadian95altima is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old Mar 7th, 2005, 06:33 PM
Superdooper Modderpooper!
 
Asleep's Avatar
 
Joined: Jan 2003
Location: Ontario, Ca
Posts: 3,192
Send a message via AIM to Asleep Send a message via Yahoo to Asleep
Quote:
Originally Posted by canadian95altima
My 93 Altima put out codes on the ECM but it appears my 95 doesn't. At least when I tried nothing happened.
Does anyone know what a scanner might cost and the manufacturer?
if youre able to go to autozone, have them do it for free.
did you happen to look up on your dash when you were looking for the codes? on the newer ecu's the check engine light is what flashing the codes - actually the older ones do too, but if i remember correctly, there isnt an led on the ecu on later models...
Asleep is offline  
post #3 of 9 Old Mar 7th, 2005, 08:12 PM Thread Starter
Sorta-Newbie
 
Joined: Mar 2005
Posts: 17
Quote:
Originally Posted by AsleepAltima
if youre able to go to autozone, have them do it for free.
did you happen to look up on your dash when you were looking for the codes? on the newer ecu's the check engine light is what flashing the codes - actually the older ones do too, but if i remember correctly, there isnt an led on the ecu on later models...

No I didn't look up there. Will just have to wait til the light comes on again. Car acting up on and off but now light not coming on
canadian95altima is offline  
post #4 of 9 Old Mar 8th, 2005, 02:00 AM
Biru O' Kudasai
 
KA24Tech's Avatar
 
Joined: Feb 2004
Location: Golden CO
Posts: 1,426
The code is still stored in the memory and the 95 is OBD II so a general code scanner should work.

Troy

SHIFT_Happiness
1992 S13 240SX SE Fastback KA24DE 5 spd
1993 U13 Altima SE KA24DET 5 spd
1990 Z32 300ZX VG30DETT 5 spd
Still trying to import a 1988 R31 Skyline GTS-R w/ RB20DET-R
KA24Tech is offline  
post #5 of 9 Old Mar 9th, 2005, 03:49 PM Thread Starter
Sorta-Newbie
 
Joined: Mar 2005
Posts: 17
Quote:
Originally Posted by KA24Tech
The code is still stored in the memory and the 95 is OBD II so a general code scanner should work.

Troy
Looked at some on the net and they say they have a 16 pin connector. The one in my car where the fuses are seems to be 14 consisting of 3 groups of four and one group of two. Is this OK does anyone know?
As well I looked on the Emission label on the underside of the hood where I understand it is suppose to say if it is OBD II and it doesn't have it.
canadian95altima is offline  
post #6 of 9 Old Mar 13th, 2005, 08:14 AM Thread Starter
Sorta-Newbie
 
Joined: Mar 2005
Posts: 17
Quote:
Originally Posted by canadian95altima
Looked at some on the net and they say they have a 16 pin connector. The one in my car where the fuses are seems to be 14 consisting of 3 groups of four and one group of two. Is this OK does anyone know?
As well I looked on the Emission label on the underside of the hood where I understand it is suppose to say if it is OBD II and it doesn't have it.
Called the Nissan dealer and even they didn't no for sure whether it is
OBD I or II. It is suppose to be on sticker on underside of hood. Does not say OBD II. The car was built in June 1995.

Another thing I noticed is that the LED light on the ECM is not on. I see there is a relay on it according to Haynes. Anybody had to replace that or maybe ECM is bad.
canadian95altima is offline  
post #7 of 9 Old Mar 13th, 2005, 11:17 AM
Superdooper Modderpooper!
 
Asleep's Avatar
 
Joined: Jan 2003
Location: Ontario, Ca
Posts: 3,192
Send a message via AIM to Asleep Send a message via Yahoo to Asleep
your car is obd2. i hate doing this but it works from time to time. try www.batauto.com these guys are very knowledgeable with computer problems. try browsing thru their site or emailing them. maybe they might know of something we are missing.
Asleep is offline  
post #8 of 9 Old Mar 22nd, 2005, 02:55 AM
Biru O' Kudasai
 
KA24Tech's Avatar
 
Joined: Feb 2004
Location: Golden CO
Posts: 1,426
I don't know why I didn't think of it before but the N-probe will work great for your car because it works for any Nissan 90-99. The connector you are referring to is the Consult Data Link Connector on the top of the interior fuse panel.
http://www.300degree.com/electronics/nprobe/

Troy

SHIFT_Happiness
1992 S13 240SX SE Fastback KA24DE 5 spd
1993 U13 Altima SE KA24DET 5 spd
1990 Z32 300ZX VG30DETT 5 spd
Still trying to import a 1988 R31 Skyline GTS-R w/ RB20DET-R
KA24Tech is offline  
post #9 of 9 Old Mar 22nd, 2005, 03:14 PM Thread Starter
Sorta-Newbie
 
Joined: Mar 2005
Posts: 17
Quote:
Originally Posted by KA24Tech
I don't know why I didn't think of it before but the N-probe will work great for your car because it works for any Nissan 90-99. The connector you are referring to is the Consult Data Link Connector on the top of the interior fuse panel.
http://www.300degree.com/electronics/nprobe/

Troy
OK thanks

Ccheck engine light just came on again afew days after having distributor replaced. This time I checked actual light on dashboard in self diagnostic mode and it flashed a code. Rear O2 sensor. I will post on this.
canadian95altima is offline  
Sponsored Links
Advertisement
 
Reply

  Nissan Forum > Altima/Stanza > U13 1993-1997 Altima

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter you desired username.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! 0312 Code - EVAP Problems LCDMAN A32 1995-1999 Chassis 0 Oct 6th, 2004 12:43 PM
MIL on but no OBD code? daemath QG18 1.8L Engine 3 Sep 16th, 2004 09:27 PM
Help, error code 45 (leaky injector???) bast525 SR-Series Engines (DE/VE) 2 Jul 13th, 2004 11:27 PM
Engine miss, stall with code 34 message jocko k U13 1993-1997 Altima 1 Feb 12th, 2004 03:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome