Idle Air Control Valve - Nissan Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old May 9th, 2006, 09:25 AM Thread Starter
Sorta-Newbie
 
Join Date: Jan 2006
Posts: 12
Idle Air Control Valve

My car is running really rough, especially during idle. Now when i hook my OBD II scanner to it, it tells me that the knock sensor is bad (which i heard doesn't really mess up the way it drives) and the Idle Air control system.
Is it true that i can just clean my Idle Air control valve? How would i clean it? Would i have to take it apart?
Should i replace the knock sensor? HOw much does it really matter? I also heard it is incredibly hard to get to.
Well thanks in advance for your help
Sponsored Links
Advertisement
 
post #2 of 4 Old May 9th, 2006, 10:30 AM
Superdooper Modderpooper!
 
Asleep's Avatar
 
Join Date: Jan 2003
Location: Ontario, Ca
Posts: 3,192
Send a message via AIM to Asleep Send a message via Yahoo to Asleep
the knock sensor can usually be cleaned and reinstalled. its a very simple part and usually excessive dirt and oil make it malfunction. its not really that hard to get to though.
the IACV on the other hand, ive tried cleaning it and its never worked for me. i cant remember exactly, but i dont remember it being exactly cheap. i think it was about 110 dollars or so...
post #3 of 4 Old May 9th, 2006, 12:17 PM
Nissan Addict
 
LONDONDERRY's Avatar
 
Join Date: May 2004
Location: Londonderry, New Hampshire
Posts: 822
Quote:
Originally Posted by AsleepAltima
the knock sensor can usually be cleaned and reinstalled. its a very simple part and usually excessive dirt and oil make it malfunction. its not really that hard to get to though.
the IACV on the other hand, ive tried cleaning it and its never worked for me. i cant remember exactly, but i dont remember it being exactly cheap. i think it was about 110 dollars or so...
I was atempting to clean the IACV assembly myself, but gave up because its to tight to get at with my hands.
Question for you Asleep, when you said "its never worked for me" are you saying that cleaning it didn't solve the idling issue I assume you had or have?


F
LONDONDERRY is offline  
post #4 of 4 Old May 9th, 2006, 07:31 PM
Superdooper Modderpooper!
 
Asleep's Avatar
 
Join Date: Jan 2003
Location: Ontario, Ca
Posts: 3,192
Send a message via AIM to Asleep Send a message via Yahoo to Asleep
i tried a couple times with the iacv on my 240. i could not get that thing to idle right for nothing... i finally gave up and bought a new one. worked fine that time. what gets me is that the old iacv didnt have noticeable carbon build-up, yet the new one worked much better.
Reply

  Nissan Forum > Altima/Stanza > U13 1993-1997 Altima

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
My 3.5se has a p0507 code, anyone know the idle relearn procedure? cobra0827 L31 2002 - 2006 18 Sep 23rd, 2014 05:42 PM
EVAP canister vent control valve closed large168 SR-Series Engines (DE/VE) 45 Mar 24th, 2013 01:08 PM
OBD II Code Chart no1see2me QG18 1.8L Engine 9 Jul 26th, 2009 03:26 PM
p1505 -idle air control system at adaptive clip nissan98 GA16DE 1.6L Engine 4 Jun 5th, 2007 11:16 AM
Idle problem, IAA Valve? K-1 S13 240SX 1989-1994 4 Jan 31st, 2005 10:36 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On