2003 Supercharged Xterra problem - Nissan Forum
Truck & SUV Armada, Frontier, Murano, Pathfinder, Quest, Titan, X-Trail, Xterra

 
LinkBack Thread Tools Display Modes
#1 Old Sep 24th, 2007, 08:20 AM
NissanForums Newbie
 
Join Date: Sep 2007
Posts: 1
2003 Supercharged Xterra problem

I'm having a problem with my Xterra and can use any help someone might have. I've had it back to the dealership 4 times and they tell me there's nothing wrong with it.

When the engine is cold, the truck drives great. Lots of throttle response and it takes off. When the engine gets hot, the motor bogs down at low RPM. It's almost like it's not firing on all cylinders or it's not getting enough fuel. Any suggestions?
sureshot-dave is offline  
Reply

  Nissan Forum > Truck & SUV

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Xterra 2006 A/C Problem miamixterra Truck & SUV 3 Feb 5th, 2007 06:16 PM
Xterra Problem desmos2r1k Frontier 1 Aug 28th, 2006 08:13 PM
2003 Sentra GXE: Brake problem, Idling squeeky ? coolwiz00 B15 2000-2006 2 Jan 26th, 2006 03:45 PM
Xterra SE Supercharger problem ctgretzky99 Forced Induction & Nitrous Oxide 5 Dec 9th, 2005 09:53 AM
Xterra Problem Ernie Truck & SUV 1 Aug 24th, 2005 01:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On