1997 Nissan XE pickup stalling - Nissan Forum
Truck & SUV Armada, Frontier, Murano, Pathfinder, Quest, Titan, X-Trail, Xterra

 
LinkBack Thread Tools Display Modes
post #1 of 15 Old Oct 29th, 2005, 08:08 PM Thread Starter
NissanForums Newbie
 
Joined: Oct 2005
Posts: 7
Question 1997 Nissan XE pickup stalling

Hi. My 1997 Nissan XE pickup with about 90,000 miles has been stalling recently and it's getting worse. It first happened about a week ago when I pulled into my brother's driveway and it quit as I came to a stop. I then drove it home and it was fine. Since then it has happened several times. It happens cold and after it has warmed up but not all the time.

I changed the fuel filter (that's a fun job!) thinking it might be something that obvious. It didn't seem to help. Still, sometimes it's fine and sometimes it tries to stall when I slow down to stop or make a turn.

The really weird thing is, when it's acting up, the turn signals don't work! (This is while driving, not necessarily when it actually stalls). The headlights, brake lights, radio, and everything else works except for the turn signals. Two minutes later it's running fine and the turn signals are working again.

The first time it happened was right after I had changed the oil and air filter. Later, when I changed the fuel filter, I checked to see if I had knocked anything loose but didn't see anything. I checked the distributor cap and cleaned some corrosion off the terminals (I still need to get a new cap). I stopped by AutoZone and he checked the battery and alternator which were fine. Beyond that, they didn't have a clue. The check engine light is not on but the ABS light flashes sometimes when it's idling and trying to stall.

I'm lost as to a relationship between the stalling and the turn signals not working. Anyone have any ideas?

Thanks,
Steve
fletchware is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old Oct 29th, 2005, 09:20 PM
Nissan Fanatic
 
Joined: Oct 2005
Location: South Carolina
Posts: 329
Quote:
Originally Posted by fletchware
Hi. My 1997 Nissan XE pickup with about 90,000 miles has been stalling recently and it's getting worse. It first happened about a week ago when I pulled into my brother's driveway and it quit as I came to a stop. I then drove it home and it was fine. Since then it has happened several times. It happens cold and after it has warmed up but not all the time.

I changed the fuel filter (that's a fun job!) thinking it might be something that obvious. It didn't seem to help. Still, sometimes it's fine and sometimes it tries to stall when I slow down to stop or make a turn.

The really weird thing is, when it's acting up, the turn signals don't work! (This is while driving, not necessarily when it actually stalls). The headlights, brake lights, radio, and everything else works except for the turn signals. Two minutes later it's running fine and the turn signals are working again.

The first time it happened was right after I had changed the oil and air filter. Later, when I changed the fuel filter, I checked to see if I had knocked anything loose but didn't see anything. I checked the distributor cap and cleaned some corrosion off the terminals (I still need to get a new cap). I stopped by AutoZone and he checked the battery and alternator which were fine. Beyond that, they didn't have a clue. The check engine light is not on but the ABS light flashes sometimes when it's idling and trying to stall.

I'm lost as to a relationship between the stalling and the turn signals not working. Anyone have any ideas?

Thanks,
Steve

find a nissan service manual or purchase and download one here: http://www.nissan-techinfo.com/nissan/

go to the back of the manual where the diagrams are to find all your ground locations. check all ground locations for corrosion, and clean if neccesary. loose grounds can cause some of the strangest things to happen. If they are all ok then it's time for a challeng of your trouble shooting skills. does it stall only when breaking? will it stall while driving or do you have to take your foot of the gas? Is it manual or atomatic trans? 4cyl or V6? 4 wheel ABS or just rear? are you positive that it's the ABS light and not the battery or engine light? does the ABS light come on during the stall or a few seconds befor or maybe a minute or two? I can think of relations of ABS and turn signals, I can think of relations of ABS and engine stalls, but I can't think of a relation between turnsignals and engine stalls without more systems also haveing problems. Can you duplicate the stall sitting in the driveway or do you have do actualy be driving for it to happen?

It's much easier to travel through a maze when you have a map!

Spat
Former Nissan Tech
14yrs ASE all but AT it's a bitXX!
New career - HandyMan/Electrician - Freedom at last!!

86.5 Nissan HB D21 234K Miles
94 Nissan Altima GXE ? Miles
97 Dodge Grand Caravan 3.8L 132K Miles
64 Chrysler 300-K 2-door Convertible 63K Miles
spat is offline  
post #3 of 15 Old Oct 29th, 2005, 11:35 PM Thread Starter
NissanForums Newbie
 
Joined: Oct 2005
Posts: 7
Thanks for your reply. Actually I wondered about a loose connection somewhere so I'll get the manual you suggested and check that out. In the meantime, here are the answers to the questions you asked.

does it stall only when breaking? Typically it stalls when I slow down to turn or stop. I've also had problems accelerating from a stop; for example, when backing out of a parking slot it kept trying to die in reverse but the engine ran smooth in neutral. I've also had other problems getting it to go, but after a few minutes of trying it eventually cooperates.

will it stall while driving or do you have to take your foot of the gas? So far it hasn't stalled while driving along.

Is it manual or atomatic trans? 4cyl or V6? Manual 4 cyl.

4 wheel ABS or just rear? I think it's just rear.

are you positive that it's the ABS light and not the battery or engine light? does the ABS light come on during the stall or a few seconds befor or maybe a minute or two? The light that comes on actually says "ABS". The times I've noticed it are when I'm trying to get the truck to go and it's trying to die on me. At those times, the ABS indicator just constantly flashes on and off. I haven't noticed it at other times (too many other things going on -- in traffic and trying to keep it from dying on me).

Can you duplicate the stall sitting in the driveway or do you have do actualy be driving for it to happen? It will sometimes do it sitting in the driveway. I've had a couple of instances where the truck just didn't want to go and would try to stall when I tried to move. Most times it will start off ok, but when I come to a stop it will just sputter and die unless I can feather the gas pedal and keep it going. But it's not every time and it always starts right back up.

Thanks again,
Steve
fletchware is offline  
post #4 of 15 Old Oct 30th, 2005, 10:32 AM
Nissan Enthusiast
 
Joined: Jan 2003
Location: Leesburg, FL
Posts: 88
Send a message via AIM to MrOldLude
If you want the service manual in pdf, I know where you can get it. Shoot me an IM, and I'll transfer it to you.

Mr. Pete
1997 Hardbody 4x4
1989 Prelude 2.0 Si
MrOldLude is offline  
post #5 of 15 Old Oct 30th, 2005, 10:55 AM Thread Starter
NissanForums Newbie
 
Joined: Oct 2005
Posts: 7
Thanks MrOldLude! I sent you a message.

Steve
fletchware is offline  
post #6 of 15 Old Oct 30th, 2005, 10:57 AM
Nissan Enthusiast
 
Joined: Aug 2004
Location: Mid-Ohio
Posts: 235
I found a great link to the FSM so you don't have to try to upload it to needy members

phatg20.net
79kz400 is offline  
post #7 of 15 Old Oct 30th, 2005, 11:33 AM Thread Starter
NissanForums Newbie
 
Joined: Oct 2005
Posts: 7
Hi 79kz400. Thanks for the link.
fletchware is offline  
post #8 of 15 Old Oct 30th, 2005, 12:11 PM
Nissan Enthusiast
 
Joined: Jan 2003
Location: Leesburg, FL
Posts: 88
Send a message via AIM to MrOldLude
A zero byte .exe? Sounds sketchy. Oh well. Good luck to ya.

Mr. Pete
1997 Hardbody 4x4
1989 Prelude 2.0 Si
MrOldLude is offline  
post #9 of 15 Old Oct 30th, 2005, 12:36 PM
Nissan Addict
 
Joined: Oct 2005
Posts: 594
Quote:
Originally Posted by MrOldLude
A zero byte .exe? Sounds sketchy. Oh well. Good luck to ya.

It's because on that kind of site, the uploader has to type in the bytes, but was to lazy. So the site defaults it to 0 bytes
Xeno is offline  
post #10 of 15 Old Oct 30th, 2005, 09:29 PM
Nissan Enthusiast
 
Joined: Aug 2004
Location: Mid-Ohio
Posts: 235
I just downloaded it to double check and its a good file. Self extracting and took about 7 minutes @ 80KBps on my DSL. This is the file that i tried to send to you mroldlude (least i think it was you) and someone named Kerry(something)when you asked me several months ago. My mail program would not allow the file size so i just packed it onto one of those generic host-all web sites (megauploads.com). Maby we could get the link stickied into that FSM manual link for the early model trucks since this site appears stable and the file won't be deleted after 30 days without D/L.

Nice PDF file to. Just click on the section and your there without having to look for stuff like my B13 FSM.
79kz400 is offline  
post #11 of 15 Old Oct 30th, 2005, 09:31 PM
Nissan Enthusiast
 
Joined: Aug 2004
Location: Mid-Ohio
Posts: 235
Oh yeah. Welcome to the forum fletchware
79kz400 is offline  
post #12 of 15 Old Oct 31st, 2005, 10:14 AM Thread Starter
NissanForums Newbie
 
Joined: Oct 2005
Posts: 7
Thanks. I downloaded the file, too, and it worked great! I really appreciate the help. Now, gotta find the time to work on the truck.

Steve
fletchware is offline  
post #13 of 15 Old Nov 3rd, 2005, 01:52 PM Thread Starter
NissanForums Newbie
 
Joined: Oct 2005
Posts: 7
UPDATE! First, I want to thank all of you for your help, especially spat for pointing me in the right direction and 79kz400 for the link to the manual.

In addition to what I already posted, I pulled into my driveway the other day and the truck went dead. While I was messing with it, I noticed that with the ignition on but engine not running, when I put it into reverse, the seat belt light got dim and the ABS light came on dim. When I put it into neutral the seat belt light and the ABS light brightened. Sounds electrical to me!

So, I searched the diagrams and ground info to find something to tie it all together. Found ground connector M177 (under the driver's side seat) was tied to ABS, turn signals, back up lights, fuel pump regulator, among other things.

So I took out the seat and found (guess what!) the ground was loose!!! I fixed that and it's running fine.

So, not only did I get my truck running right, but I got all the trash cleaned out from under my seat, AND I found 92 cents !!!

THANKS AGAIN !!!

Steve
fletchware is offline  
post #14 of 15 Old Nov 4th, 2005, 01:34 AM
Nissan Fanatic
 
Joined: Oct 2005
Location: South Carolina
Posts: 329
Thumbs up

Quote:
Originally Posted by fletchware
UPDATE! First, I want to thank all of you for your help, especially spat for pointing me in the right direction and 79kz400 for the link to the manual.

In addition to what I already posted, I pulled into my driveway the other day and the truck went dead. While I was messing with it, I noticed that with the ignition on but engine not running, when I put it into reverse, the seat belt light got dim and the ABS light came on dim. When I put it into neutral the seat belt light and the ABS light brightened. Sounds electrical to me!

So, I searched the diagrams and ground info to find something to tie it all together. Found ground connector M177 (under the driver's side seat) was tied to ABS, turn signals, back up lights, fuel pump regulator, among other things.

So I took out the seat and found (guess what!) the ground was loose!!! I fixed that and it's running fine.

So, not only did I get my truck running right, but I got all the trash cleaned out from under my seat, AND I found 92 cents !!!

THANKS AGAIN !!!

Steve
Haveing good reference sure helps! just for kicks, next time your in a parts store try looking up that info in a generic manual!

It's much easier to travel through a maze when you have a map!

Spat
Former Nissan Tech
14yrs ASE all but AT it's a bitXX!
New career - HandyMan/Electrician - Freedom at last!!

86.5 Nissan HB D21 234K Miles
94 Nissan Altima GXE ? Miles
97 Dodge Grand Caravan 3.8L 132K Miles
64 Chrysler 300-K 2-door Convertible 63K Miles
spat is offline  
post #15 of 15 Old Nov 4th, 2005, 10:58 AM Thread Starter
NissanForums Newbie
 
Joined: Oct 2005
Posts: 7
Quote:
Originally Posted by spat
Haveing good reference sure helps! just for kicks, next time your in a parts store try looking up that info in a generic manual!
I know what you mean. I have a Haynes manual for it -- it's virtually worthless! It covers 1980 - 1997 models (like nothing changed in 18 model years!?!).
fletchware is offline  
Sponsored Links
Advertisement
 
Reply

  Nissan Forum > Truck & SUV

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter you desired username.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 & 2005 Armada brake problem Shannonop Titan & Armada 15 Sep 15th, 2013 11:51 AM
96 Nissan 200SX to be in Gran Turismo 4 WRXrob General Discussion 21 Nov 1st, 2004 12:34 AM
Gran Turismo 4 niky Off Topic 88 Oct 24th, 2004 04:43 PM
Warning about Rodeo Nissan in Fresno FadedKM83 Southwest 8 Mar 30th, 2004 02:16 AM
95 Nissan Pickup XE V6 - speedometer and cruise control sometimes stops working... SunDog Truck & SUV 2 Jul 18th, 2002 02:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome