EGI Fuse??? - Nissan Forum
S13 240SX 1989-1994 Including Silvia

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Mar 20th, 2005, 02:07 AM Thread Starter
Nissan Enthusiast
 
Matrix021's Avatar
 
Joined: Aug 2002
Location: Stockton, CA
Posts: 35
Send a message via AIM to Matrix021
Unhappy EGI Fuse???

Okay... here's a bonehead question... What the hell does EGI stand for and what does it do? I looked in my fuse panel in my engine compartment and noticed that it's just plain missing. It's the big green one on the left. I can tell by the look of the looks of it that there was a fuse there and it's just gone...An investigation on a couple of different forums told me that it's the Electronic Fuel Ignition Relay... but for whatever reason, it's marked EGI on the cover.... is this true? Second part of the question... how is it that my car doesn't have the fuse installed in the fuse block yet my car runs?

I'm confused as hell... help anyone?

And that's my 2 cents....
Matrix021 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Mar 21st, 2005, 07:59 PM Thread Starter
Nissan Enthusiast
 
Matrix021's Avatar
 
Joined: Aug 2002
Location: Stockton, CA
Posts: 35
Send a message via AIM to Matrix021
Anyone? I just wanna know what the heck it's supposed to do. I went by the PnP and snagged me a few of them green fuses to replace it. It's installed now... but there's no change. What should I be looking for?

And that's my 2 cents....
Matrix021 is offline  
Sponsored Links
Advertisement
 
Reply

  Nissan Forum > 240SX/Silvia/S12 200SX > S13 240SX 1989-1994

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter you desired username.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuse Box. Missing! bjl97sen B14 95-99 chassis 1 Feb 14th, 2010 10:53 PM
Computer Testing?????????????? myaltimaskillingme U13 1993-1997 Altima 3 Mar 7th, 2005 02:55 AM
Fuse question. live4snow B13 91-94 chassis 4 Jan 6th, 2005 08:39 PM
A/T CONT Fuse. HELP!!!!!! Tan Frontier Truck & SUV 11 Aug 25th, 2004 02:34 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome