2001 Sentra has no power - Nissan Forum
QG18 1.8L Engine Engine Discussion: 2000+ Sentra XE, GXE, & 1.8

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old May 28th, 2005, 10:29 PM Thread Starter
Sorta-Newbie
 
BillBill97's Avatar
 
Joined: May 2005
Location: Texarkana
Posts: 13
2001 Sentra has no power

Iíve exhausted all of my resources to figure out the power problem. It started with O2 bank 2 errors. I replaced both of them. When it died the second time, Nissan dealer replaced the cam shaft sensors because of the update. They would not let me do it. When I got it back it ran sluggish. I should have carried it back but the power would come and go. Also, I thought that they created the issue. It ran fine before the second set of cam sensors. It did give a lean mixture error. These happen about 12 months ago.

Now it has no power and no errors. I started with the regulator. Replaced it and when I pinched the return line the power came back. Fuel pump and screen have been replaced. Injectors were pulled twice and cleaned. They show no signs of leakage and spray a good mist. Computer has even been replaced. Monitoring the O2 sensor, they read OK when the fuel pressure is at 50+.

The next step was to carry it to a different shop but that shop spent a whole week on it with no fix. They reported that all the timing and pulse width are correct. They even went down the same road I did with fuel.

The car idles OK for 15 seconds; then it goes into an open loop, fuel fault error. With the return pinched to hold 50 lbs. That error does not come back and O2 readings are returned to normal values.

They only error that come up are shifting gear errors. I am looking for any directions.
BillBill97 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old May 29th, 2005, 03:52 PM
absolutely classic
 
Kindfiend's Avatar
 
Joined: Oct 2004
Location: Phila.
Posts: 455
Well, you tried everything I would have tried... The only time it runs decent is when you pinch the return fuel line? I can't give you an answer, but I'll give you a free bump until someone comes along who can help you better. Good luck, it's probably something simple like a bad ground or leak somewhere.

Kindfiend

01 Sentra GXE
92 SE-R
Kindfiend is offline  
post #3 of 8 Old May 29th, 2005, 04:13 PM
Powered By hopes & dreams
 
chimmike's Avatar
 
Joined: Oct 2002
Location: SRQ
Posts: 8,328
Send a message via AIM to chimmike
just for the hell of it, have them change the exhaust manifold gaskets and tighten them all down to stock torque settings as well as the header/secondary connection.

check the MAF

only real motored toys left:
'06 GSX-R 1000
'07 Mazdaspeed3- injen CAI.
chimmike is offline  
post #4 of 8 Old May 30th, 2005, 01:14 PM Thread Starter
Sorta-Newbie
 
BillBill97's Avatar
 
Joined: May 2005
Location: Texarkana
Posts: 13
Thanks KF,

The grounds are the only thing that I haven't check. The MAF is reading properly and I am trying a new ST this week. It has a few more features and if it works out. I will let you guys know where the problem lies.

I guess Nissan is using the O2 sensor to regulate instead of monitor. This is a stange way but whats NEW!!
BillBill97 is offline  
post #5 of 8 Old Jun 2nd, 2005, 09:27 PM Thread Starter
Sorta-Newbie
 
BillBill97's Avatar
 
Joined: May 2005
Location: Texarkana
Posts: 13
Quote:
Originally Posted by Kindfiend
Well, you tried everything I would have tried... The only time it runs decent is when you pinch the return fuel line? I can't give you an answer, but I'll give you a free bump until someone comes along who can help you better. Good luck, it's probably something simple like a bad ground or leak somewhere.
KindFriend.

After waiting for input and checking and rechecking electical connections, exhaust and intake leaks. I finally resolved the issue. It is all of the injectors. The mist is lean on 1 & 2. Number 3 is spraining correctly and 4 is delivering a stream but not a true mist. Just thought I would let you guys know.

Some important findings that might help others. When I replaced the fuel pump, regulator and fuel screen, the fuel screen had a rusty color liquid to it. I think that is what plugged the injectors since nissan doesn't use a fuel filter to catch this. This has been a year and a half problem that started with bank 2 O2 errors. Replaced them twice. Errors still present. Then the power slow decreased over that time with lean errors and then it would not get over 20 mph three weeks ago.

I would recommend to keep the fuel tank above a 1/4. This will keep the pump submerge and help cool it. Watch the type of gas you put in and if all goes south. SELL IT!!!


PS>>I found a set of four for $100 dollars

Last edited by BillBill97; Jun 2nd, 2005 at 09:29 PM.
BillBill97 is offline  
post #6 of 8 Old Jun 2nd, 2005, 10:29 PM
absolutely classic
 
Kindfiend's Avatar
 
Joined: Oct 2004
Location: Phila.
Posts: 455
Sounds like your getting bad gas. Good thought on checking the injectors, however. I'm glad you were able to figure out everything.

edit: excellent price for those injectors, where did you find them for that cheap?

Kindfiend

01 Sentra GXE
92 SE-R
Kindfiend is offline  
post #7 of 8 Old Jun 3rd, 2005, 09:07 AM Thread Starter
Sorta-Newbie
 
BillBill97's Avatar
 
Joined: May 2005
Location: Texarkana
Posts: 13
Quote:
Originally Posted by Kindfiend
Sounds like your getting bad gas. Good thought on checking the injectors, however. I'm glad you were able to figure out everything.

edit: excellent price for those injectors, where did you find them for that cheap?
This site has them for $34.99 each (http://www.injectors4u.com/)

And this one for $100 set +core charge(http://www.suncarb.com/Prices.html)

We'll let you know if they are any count.
BillBill97 is offline  
post #8 of 8 Old Jun 29th, 2005, 11:18 AM
NissanForums Newbie
 
Joined: Jun 2005
Posts: 1
Hello every one.... Im new on this forum... I got a 2001 sentra...and i got the same problem.... No power... And no one of my mechanics can find a problem... Bye..
SentraRider is offline  
Reply

  Nissan Forum > Sentra, Pulsar, NX, B14 200SX > QG18 1.8L Engine

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter you desired username.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
THE GT4 THREAD HATEnFATE Off Topic 353 Apr 7th, 2005 07:43 AM
Sentra Power Loss riversideguy GA16DE 1.6L Engine 9 Aug 29th, 2004 05:58 PM
2001 Sentra Auto Trans fluid... manydubs B15 2000-2006 2 Jun 14th, 2004 09:15 AM
New guy.. Need help on power mods to my 91 4dr sentra... 03SubaWRX B13 91-94 chassis 5 Apr 26th, 2004 06:55 PM
2001 Sentra SE 3.5 engine swap hobbie2k B15 2000-2006 3 Sep 30th, 2002 09:49 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On