Running Boards rusted out... 98 QX4 - Nissan Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Aug 16th, 2005, 09:33 AM Thread Starter
Nissan Enthusiast
 
Joined: Feb 2005
Location: Cincinnati, OH
Posts: 28
Running Boards rusted out... 98 QX4

My running boards have a main support that is a square, hollow metal tube about 1.5" wide. It has rusted completed through (only rusty thing on the car). I was thinking about going to Home Depot and buying a similar sized / length piece of aluminum and replacing these old ones. Has anyone tried this before?

It seems as simple as removing the old running boards (plastic and all)... removing the old hollow bar and replacing it with the new aluminum one. Make sense?

'98 Infiniti QX4, Pearl White/Champaign on Tan
www.jasonrmanuel.com

Last edited by Jason82; Aug 16th, 2005 at 09:40 AM.
Jason82 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Aug 16th, 2005, 01:51 PM
b67
Nissan Fanatic
 
Joined: Apr 2004
Posts: 277
Quote:
Originally Posted by Jason82
My running boards have a main support that is a square, hollow metal tube about 1.5" wide. It has rusted completed through (only rusty thing on the car). I was thinking about going to Home Depot and buying a similar sized / length piece of aluminum and replacing these old ones. Has anyone tried this before?

It seems as simple as removing the old running boards (plastic and all)... removing the old hollow bar and replacing it with the new aluminum one. Make sense?
any pics of what you are talking about??
b67 is offline  
Sponsored Links
Advertisement
 
Reply

  Nissan Forum > Truck & SUV > Pathfinder

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter you desired username.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Tail / running light fuse on '98 Pathfinder? algae Pathfinder 2 Jul 26th, 2005 09:21 AM
'01 Pathfinder Vibration at 1500RPM - shaking running boards? nocdmike Pathfinder 3 May 18th, 2005 08:11 PM
98 Frontier 4x4 Running Lights Infantryboots Frontier 3 Apr 11th, 2005 06:19 AM
How to test / adjust TPS in a 98 QX4? Jason82 Truck & SUV 1 Mar 13th, 2005 07:34 AM
Stromung Group Deal Ninety-Nine SE-L Group Buys 142 Mar 4th, 2003 12:19 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome