Nissan Forum - View Profile: SPEEDO

SPEEDO SPEEDO is offline

I Live Here

  Visitor Messages

Showing Visitor Messages 1 to 6 of 6
  1. Grug
    Apr 5th, 2014 05:35 PM - permalink
    Grug
    Hey there, Speedo.

    Looking at an '01 Xterra (V6, manual) 85 000 miles. I've heard things to look out for are timing belt, exhaust manifold cracks and distributor bearing. Anything else significant come to mind?

    I looked on the forum, but there isn't really a section for Xterras.

    Thanks!
    Grug
  2. SPEEDO
    Jan 26th, 2012 04:56 PM - permalink
    SPEEDO
    By vin, a turbine sensor does come up! pt#31935-42X78 ,it does use a gskt pt# 31388-51X00
    sensor runs $152.37 (internet price $114.28)
    gskt $3.58 (internet price $2.69)
    anything else, dont hesitate, I will at least try to help! :)
  3. Gordy09
    Jan 26th, 2012 03:52 PM - permalink
    Gordy09
    JN8DR09X64W801353
  4. Gordy09
    Jan 26th, 2012 03:50 PM - permalink
    Gordy09
    JN8DR09X64W801353
    You have no idea how much I appreciate the help
  5. SPEEDO
    Jan 25th, 2012 10:52 AM - permalink
    SPEEDO
    sounds like a blower resistor, mounted on the blower case, pull the glove box (2 hinge pins) then the metal plate to get to the case
    oem pt# 27150-06J01, they run about $15 online..
    Hope it helps
  6. Zaylor
    Jan 24th, 2012 04:45 PM - permalink
    Zaylor
    Hi, I saw a post by you that indicated you would have the answer to this question.

    The blower motor on my 91 nissan hardbody only works on speeds 1,2,3. It doesn't work on 4. It also makes a squealing noise upon startup. Info on what to check would be greatly appreciated.

    Thanks,
    Taylor

  About Me

  • About SPEEDO
    Car
    02 Spec-V, 86.5 Hardbody
    Location
    PHX AZ
  • Signature

  Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Dec 19th, 2014 09:52 AM
  • Joined: Jun 9th, 2003

  Mentions

No results to display...

  Thread Tags

No results to display...

  Quotes

Nov 7th, 2014
08:25 PM - pathfinders quoted SPEEDO in post brake pads to choose
bedding is another word for...
Oct 30th, 2014
07:30 PM - smj999smj quoted SPEEDO in post Nissan Altima Radio display not working. Help? (Picture included)
might hit up your local dea...
Oct 24th, 2014
11:38 AM - Spongerider quoted SPEEDO in post Broken Belts?
do yourself a favor and rep...
Sep 4th, 2014
11:29 PM - jrmast quoted SPEEDO in post Oil Pressure 05 Altima SE R
migh check into the oil pre...
Jul 30th, 2014
02:21 PM - dcalleja777 quoted SPEEDO in post Intake Manifold Question
...t cheaper online SPEEDO do you know if the 2...
Jul 22nd, 2014
11:27 AM - BRubble quoted SPEEDO in post Fuel Level and Performance Correlation
I do not, sorry.. I dont kn...
11:06 AM - BRubble quoted SPEEDO in post Fuel Level and Performance Correlation
I remember the V6's had a i...
Jun 20th, 2014
10:14 AM - jp2code quoted SPEEDO in post 1993 nissan d21
I was thinking, is this a 4...
07:53 AM - jp2code quoted SPEEDO in post 1993 nissan d21
have you tried to pull any ...
Jun 19th, 2014
02:36 PM - jp2code quoted SPEEDO in post 86.5 D21 VG30i AT 2Wd Will not fire.
I had a injector go out, th...
Jun 13th, 2014
02:26 PM - lover_boy1242005 quoted SPEEDO in post Can not use remote from more than 1m Distance
there is a antenna (small b...
May 6th, 2014
02:02 PM - TheRepairMan quoted SPEEDO in post Electric cooling fan and controller, done!
I have been wanting to do t...
12:02 AM - mark0006 quoted SPEEDO in post 1971 Datsun 510 Racer - BRE-Style
for a moment I thought I kn...
Apr 21st, 2014
07:15 PM - thatchsf quoted SPEEDO in post Mechanic put in wrong cv joint/half shaft/axle
how did it go from fixing a...
Apr 10th, 2014
04:43 PM - ElderJefferson quoted SPEEDO in post 2005 Sentra Electrical Issues
batt connection good? any c...
Feb 2nd, 2014
03:09 PM - VDubHippyOx quoted SPEEDO in post Lifting a 2wd Hardbody???
with a 2" bl, I adjusted th...
Jan 13th, 2014
11:04 AM - SPEEDO quoted jmunsey in post high fluctuating idle
my 2004 Nissan sentra SE-R S...
Jan 3rd, 2014
01:56 PM - mister2 quoted SPEEDO in post Autocross
good job! are you running ...
 
For the best viewing experience please update your browser to Google Chrome