2004 altima cranks but wont start need help - Nissan Forum
 
LinkBack Thread Tools Display Modes
#1 Old Jan 8th, 2010, 12:20 AM
NissanForums Newbie
 
Join Date: Jan 2010
Posts: 1
2004 altima cranks but wont start need help

hey guys i need help wit my 2004 nissan altima a few days ago it would just crank so i ended up changing the crankshaft position sensor and so it worked for 2 days then the car wouldnt star once again the motor turns but it dosent crank up
silviacrazy is offline  
Sponsored Links
Advertisement
 
#2 Old Jan 8th, 2010, 07:20 PM
Nissan Enthusiast
 
Join Date: Oct 2009
Location: B'ham, AL
Posts: 157
Send a message via AIM to NALtech
If you didn't put a nissan OEM CPS on there I'm gonna bet that you need another crank sensor.
#3 Old Jan 11th, 2010, 09:02 PM
NissanForums Newbie
 
Join Date: Jan 2010
Posts: 1
Quote:
Originally Posted by silviacrazy View Post
hey guys i need help wit my 2004 nissan altima a few days ago it would just crank so i ended up changing the crankshaft position sensor and so it worked for 2 days then the car wouldnt star once again the motor turns but it dosent crank up
i did the same thing on my 2006 frontier le v6,it just died on me 2 weeks ago,i went to nissan and bought the sensor and changed the cranshaft position sensor,it worked for a few hours and now it wont start???sometimes the truck turns on,but its misfiring bad...then my overdrive light on stays on,even when i push the button on shifter to turn it off,it wont....
#4 Old Jan 20th, 2010, 09:23 PM
Nissan Addict
 
Join Date: Jan 2006
Location: Chattanooga, TN
Posts: 716
Send a message via AIM to Outkast
Quote:
Originally Posted by victor741 View Post
i did the same thing on my 2006 frontier le v6,it just died on me 2 weeks ago,i went to nissan and bought the sensor and changed the cranshaft position sensor,it worked for a few hours and now it wont start???sometimes the truck turns on,but its misfiring bad...then my overdrive light on stays on,even when i push the button on shifter to turn it off,it wont....
You need to get the IPDM checked and replaced. Those are becoming a pain lately.

Quote:
Originally Posted by silviacrazy
hey guys i need help wit my 2004 nissan altima a few days ago it would just crank so i ended up changing the crankshaft position sensor and so it worked for 2 days then the car wouldnt star once again the motor turns but it dosent crank up
OEM replacement CPS are junk but aftermarket ones are even worse. If it's dead you should have a CPS code stored again. There is a recall on that year for the CPS so call a local dealer and have them run a servcom on you VIN to see if it's still open.

Nissan Master Tech, Mtn View Nissan Chattanooga, TN
Reply

  Nissan Forum > Altima/Stanza > L31 2002 - 2006

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On